explorer causing 50% cpu usage?

Discussion in 'Windows Applications' started by zapoqx, Dec 8, 2008.

  1. zapoqx

    zapoqx Striking Master

    Messages:
    461
    Location:
    AZ, USA
    I don't recall explorer needing that much, but recently, that has been the case. I only noticed it recently, and in the past, I don't recall it ever using that much. Anyone ever see this before and what could be the cause of Explorer.exe using 50% CPU?
     
  2. LordOfLA

    LordOfLA Godlike!

    Messages:
    7,027
    Location:
    Maidenhead, Berkshire, UK
    If you open explorer and then click tools > folder options > view check "launch folder windows in a seperate process" should help.

    This is usually caused by a corrupt or misbehaving shell extension.
     
  3. profquatermass

    profquatermass OSNN Junior Addict

    Messages:
    36
    Location:
    Livingston, Scotland
    Explorer in XP is single minded so takes an age to do anything that has a slow network object on it, like a shortcut to another drive or computer across a network or the Internet for example.

    So if you have a bad shortcut (or bad image if its a graphic file), XP tries to render the icon and waits until the network component gets back to it. It will not give up until the network component gives up first. It's a bad flaw.

    I believe they fixed this on Vista.
     
  4. zapoqx

    zapoqx Striking Master

    Messages:
    461
    Location:
    AZ, USA
    Well I did what you said lordofLA, but it seems its not changing the cpu usage.
    The only thing I can think of is the network folders from my roommate's computer if we talk about the across the network and I don't really have anything linking to it.
    My system still runs rather quick though. It just annoys me that I have 50% of the cpu taken by explorer when I usually am seeing System Idle Process being the highest.
     
  5. Dark Atheist

    Dark Atheist Moderator Political User Folding Team

    Messages:
    6,376
    Location:
    In The Void
    what files are you trying to access? videos?

    post a hijackthis log and run spybot search and destroy, like lord said and like i am thinking this can be caused by a corrupt avi file, there are ways around this issue, that is if its avis its playing up on :)
     
    zapoqx likes this.
  6. LordOfLA

    LordOfLA Godlike!

    Messages:
    7,027
    Location:
    Maidenhead, Berkshire, UK
    then you have a missbehaving shell extension. hijack this will give more of a clue.
     
    zapoqx likes this.
  7. Dark Atheist

    Dark Atheist Moderator Political User Folding Team

    Messages:
    6,376
    Location:
    In The Void
    corrupt jpegs can cause this behaviour too, well any format windows tries to get an image preview from :)
     
  8. LordOfLA

    LordOfLA Godlike!

    Messages:
    7,027
    Location:
    Maidenhead, Berkshire, UK
    only remote media in my experiance...
     
  9. profquatermass

    profquatermass OSNN Junior Addict

    Messages:
    36
    Location:
    Livingston, Scotland
    I guess you've looked at all your shortcuts in the Start menu?

    Run a free program called CCleaner and only get it to examine your Shortcuts.
    http://www.ccleaner.com/

    See System: Start Menu Shortcuts

    If that doesn't help then you need to dig deeper and use the free ShellExView program. This allows you to temporarily disable all shell extensions hanging onto Explorer.
    Look at all 'Context Menu' and 'Shell folder' types (you may have other types) and disable them, reboot, see how Explorer performs, start re-enabling them, reboot and re-examine. That way you'll find the one causing the problem.

    Read the authors web page for a detailed description.

    Don't forget to make a Restore point BEFORE you fiddle. :)


    http://www.nirsoft.net/utils/shexview.html
     
  10. zapoqx

    zapoqx Striking Master

    Messages:
    461
    Location:
    AZ, USA
    Well in terms of doing that, I'll have to wait till Friday. So I will post back on Friday when I do it.
     
  11. zapoqx

    zapoqx Striking Master

    Messages:
    461
    Location:
    AZ, USA
    Update:
    Well I was doing something rather quick and I was confused as to why my system was running rather slow for a bit when I got back home. This is rather late of me. I checked and I was running explorer.exe TWICE. I don't know how. I closed the one that wasn't updating and it sped my system up a bit. I went into the services in MSConfig (Probably other methods but I am doin this quick)... there was something strange in Services:

    ##Id_String1.6844F930_1628_4223_B5CC_5BB94B879762##

    Ya I know know what that was about. I must go off to study and wake up early. I'll check back sometime today.... at some point...
     
  12. Dark Atheist

    Dark Atheist Moderator Political User Folding Team

    Messages:
    6,376
    Location:
    In The Void
    that is bonjour service - guessing you have cs3 installed

    to remove it open a cmd prompt

    sc stop "Bonjour Service"
    sc delete "Bonjour Service"

    Then go to the Bonjour folder and delete the .exe. There is also a dll that cannot be deleted. Change the name of the dll and reboot, and then delete it. AFter that, you need to run a free downloadable program called lspfix, because Bonjour fouls yet something else up.

    Just click ok as it will select the bonjour entry
     
    Last edited: Apr 12, 2012
  13. LordOfLA

    LordOfLA Godlike!

    Messages:
    7,027
    Location:
    Maidenhead, Berkshire, UK
    explorer will run twice if you told it to run folders in a seperate process as I suggested. IT allows you to kill the file manager part without killing your whole desktop too :)
     
  14. zapoqx

    zapoqx Striking Master

    Messages:
    461
    Location:
    AZ, USA
    Ok, time for my update...
    Ok it all works perfect again. It was indeed a corrupted video I had that was the majority of the issue. Carpo, thanks for the bonjour thing. Ya I have CS3 installed.
    Oh and Thanks LA for the nifty little feature I never noticed.