Encryption is grayed out.............

Discussion in 'Windows Desktop Systems' started by mfascett, Sep 20, 2002.

  1. mfascett

    mfascett Guest

    I notice that when I right click on a file or folder in explorer, select properties, general, advanced, under compress or encrypt attributes, I notice that the compress is okay, but the option to encrypt is greyed out. I converted to NTFS, but I must have disabled a service or something in my registry. Can some please tell me how to enable it again.
    Thanks.
    :(
     
  2. chastity

    chastity Moderator Political User

    Messages:
    2,273
    Location:
    Arizona near the Grand Canyon
    Nope, u didn't disable a service or anything. The problem is on an NTFS file system if a file is compressed it can't be encrypted, also if a file is encrypted it can't be compressed. So to be able to encrypt a file u must uncompress it.
     
  3. mfascett

    mfascett Guest

    Not compressed.....

    That is just the problem. The file is not compressed. The option to compress it is available but the option "Encrypt contents to secure data" is completely greyed out. I tested this on a document, which was not compressed.
     
  4. chastity

    chastity Moderator Political User

    Messages:
    2,273
    Location:
    Arizona near the Grand Canyon
    Well ok then thats just plain weird. Ok I'm guessin u have ur system configured to show compressed and encrypt to be displayed in different colors.
     
  5. mfascett

    mfascett Guest

    Baffled am I..........

    I just don't get it. The services that I disabled mention nothing about file encryption. I had to have turned it off somehow. I shall try to figure this out. Thanks for your help. By the way, if you do live near the Grand Canyon, then you are the luckiest person in the world. I live in New York and had always wanted to see the Grand Canyon in person.
     
  6. Rootz

    Rootz Guest

    Try checking the *local security policy* snap-in under *public key properties*/*Encrypted Data Recovery Agents*

    Encrypted File System (EFS) works only if a policy for recovery is defined. Normally the administrator is the default recovery agent. If there is no recovery agent then you won't be able to encrypt files.
    If needed you can add a new recovery agent (authenticated user) through the above snap-in.
     
  7. XP Abuser

    XP Abuser Guest

    im guessing your using xp pro cuz home its disabled to my knowledge
     
  8. mfascett

    mfascett Guest

    Yeah, I am using Home............

    What the hell. Why even show it greyed out if there is no way to enable it anyway. Don't put it there to begin with if it is not going to be an option. This sucks. I have been thinking about getting the pro version, I just wish I knew of this before I spent the money on Home.
     
  9. chastity

    chastity Moderator Political User

    Messages:
    2,273
    Location:
    Arizona near the Grand Canyon
    Re: Yeah, I am using Home............

    I agree with you.:mad:

    Thanks for the info XP Abuser:)
     
  10. Rootz

    Rootz Guest

    You're right!!
    WindowsXP Home should be banned worldwide as well as WinME and 56K modems!
     
  11. DrMetallica

    DrMetallica OSNN Senior Addict

    Messages:
    301
    Yeah, that's what i thought. But a microsoft OS is still a microsoft OS.

    Nothing really changes...

    If you want encryption (and protection of folders/files from other users on your computer) get MaxCrypt 1.0. You can drag n drop the folders you want to encrypt, password protect EVERYTHING, change filenames to random 10101001, make the system files/hidden, etc. And it will all change back when you enter the password and decrypt it :)