Enabling DMA in XP?

Discussion in 'Windows Desktop Systems' started by Streamer, Mar 11, 2002.

  1. Streamer

    Streamer Guest

    Is there a way to do this. I think this would help my burner situation but the old ways of doing this no longer apply. any suggestions?
     
  2. DrX

    DrX Guest

    99.9 % XP will automatically choose DMA mode if the device supports it

    Go into Device manager Expand IDE ATA/ATAPI and Right click on Primary or secondary controller then Properties then click on the advanced settings tab

    Choose DMA if available
     
  3. Streamer

    Streamer Guest

    thanx Drx for the fast reply. I will check it out now.
     
  4. DoubleClick

    DoubleClick Guest

    I had problem with XP not auto setting udma66 so I found this reg file at www.regedit.com that enables udma 66 and 100 on Windows 2000 or XP. I have attached the reg file to do this with.
     
  5. Streamer

    Streamer Guest

    Excellent DoubleClick. I am sure this will do the trick!

    Thanks
     
  6. Qumahlin

    Qumahlin Moderator

    Messages:
    2,006
    That regfile does not necessarily enable DMA, there was a problem in 2k/XP where on some intel chipsets UDMA was not enabled and that regedit will enable it, it's the same as using the UDMA tweak in TweakXP and those type of programs, but if you are having DMA problems and aren't using an intel chipset that reg will do nothing

    Just FYI
     
  7. DoubleClick

    DoubleClick Guest

    Qumahlin: Thank you I forgot to add that to my message I was kinda in a hurry to go pick up my daughter.

    I think it was mostly Via chipsets that had the problem if I remember correctly. However i'm not sure.
     
  8. Qumahlin

    Qumahlin Moderator

    Messages:
    2,006
    no prob man :), some people actually didn't know that so I figured I might as well post it before people start complaining it doesn't work :p