Drives stuck in PIO mode

Discussion in 'Windows Desktop Systems' started by G|ass, Nov 17, 2002.

  1. G|ass

    G|ass Guest

    Drive C, my primary master, and my DVD drive, my secondary master operate only in PIO mode even though DMA is selected. They support DMA, I've been using them in DMA forever. Drive D, my primary slave, and my CDRW drive, the secondary slave, both operate in DMA mode just fine. How the hell do I get the other two into DMA mode? The speed on these drives is unbelievably slow.
     
  2. Gus K

    Gus K NTFS abuser

    Messages:
    380
    Location:
    USA
    I would first try installing the latest 4 in1 VIA drivers. I guess device manager looks similiar to the JPG I've attached.

    In the BIOS is DMA/UDMA enabled for all IDE devices?

    You could try pulling your secondary master, and install your slave there as master, and see if it works there in DMA.

    Did this just start doing this out of the blue? Or have you made some changes?
     
  3. G|ass

    G|ass Guest

    I installed the latest 4 in 1 drivers, DMA is enabled for all drives in BIOS, I'll try swapping next time I reboot. I went in device manager and made sure DMA was selected too. I don't know how it happened, I didn't mess around with it.
     
  4. Taurus

    Taurus hardware monkey

    Messages:
    3,206
    Location:
    Sacramento, CA
    the other day i noticed my burner was in "multi-word dma 2"... so basically pio, like 16.67mb/sec. i know that when i first put it in a couple months ago it was dma33 (mode 3) just fine. well, yesterday i reformatted for other reasons and now it's back to dma mode 3. something happens at some point to cause windows to change it. no idea what. i'll check it time to time and see if i can pin-point it.
     
  5. rettahc

    rettahc Guest

    I seen other threads about this problem and for most people the answer seems to be physically unistall the device's booting up without the devices, and then reinstall them. but I don't know how you would go about doing that for your C drive, you may need to reinstall to fix it.
     
  6. BonyTony

    BonyTony Moderator

    Messages:
    788
    Give this a try....

    It worked for me and many others...posted same solution before in here always try a search first m8.

    Open REGEDIT and find the following keys:

    HKEY_LOCAL_MACHINE\SYSTEM\currentcontrolset\control\class\ {4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

    Last four digits are likely 0001, 0002. Under those keys you will find MasterIDdataChecksum, SlaveIddataChecksum. Delete the value corrosponding to your drive by right clicking on the master and slave checksums and then choose modify and delete the value data box contents do this to both 0001 and 0002 lines. It will make th OS redetect the drive DMA capabilities after rebooting.
    If it works for you too please say so...thanks.
     
  7. Arthurking

    Arthurking Guest

    I've had this happen to me too, on an SIS 630/730 chipset. I thought that it was because of the chipset, a guy replied to my post said something about that if windows detects too many errors written to disk it automatically lowers the transfer rate to compensate, or someting like that.
     
  8. G|ass

    G|ass Guest

    Problem solved

    I edited the registry per Tony's instructions and then uninstalled the offending drives and when I rebooted they were back in Ultra DMA mode. Thank you so much people for your help. I have my PC back!
     
  9. Gus K

    Gus K NTFS abuser

    Messages:
    380
    Location:
    USA
    Nice job Tony.
     
  10. maz4ruth

    maz4ruth Guest

    Thanks tony!!! :D
     
  11. Henyman

    Henyman Secret Goat Fetish Political User

    hmmmmm either you have reallyyyyy slow reaction, your lagged 2 buggery or that was useles spam


    hmmmmm:rolleyes:
     
  12. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    Mode 1 - 16.67
    Mode 2 - 33
    Mode 3 - 50
    Mode 4 - 66.67
    Mode 5 - 100
    Mode 6 - 133

    Just FYI