Disable CD Autoplay

Discussion in 'Windows Desktop Systems' started by peterbrown, Dec 24, 2001.

  1. peterbrown

    peterbrown Guest

    The tip listed on this site (using gpedit.msc) works only for Win XP Pro, not the Home Edition. To disable autoplay in Win XP home:


    Click Start , click Run , type regedit in the Open box, and then press ENTER.

    Locate and click the following registry key:

    To disable automatically running CD-ROMs, change the Autorun value to 0 (zero). To enable automatically running CD-ROMs, change the Autorun value to 1.

    Restart your computer.

    NOTE : This method disables automatically running CD-ROMs. If you want to disable automatically running CD-ROMs depending on the CD-ROM that you insert in the CD-ROM drive, you can press and hold down one of the SHIFT key while you insert the CD-ROM.


    This info. can be found in MS Knowledge Base Article Q155217

  2. Lonman

    Lonman Bleh!

    Get yourself a copy of XP Powertoys. Use Tweak UI to disable Autoplay... see if that works for you.
  3. peterbrown

    peterbrown Guest

    Tweak UI vs RegEdit

    Tweak UI only allows you to modify the exiting Win XP defaults for AutoPlay (as in right-clicking the CD ROM drive in My Computer), not disable it entirely...the Win98 Tweak UI did have the turn-off autoplay completely feature.
  4. bobdouglas

    bobdouglas Guest


    I think the trouble is although I have it eanvble in tweakui,
    CD roms in CD-rw or DVD drive do not usually autorun.
  5. yorobbo

    yorobbo Guest

    n1 peterbrown :)
  6. Krux

    Krux Nissan Powered

    can't you just hold shift down when you put a cd in???