Disable Active Desktop

Discussion in 'Windows Desktop Systems' started by russ, Mar 30, 2002.

  1. russ

    russ Guest

    OK, I give up! How do I disable the active desktop? I have a utility to change icon text color but it will not function while the desktop is active.
     
  2. rodneyck

    rodneyck Guest

    Russ,

    I think you need to right click anywhere on your desktop then;
    properties>desktop>customize desktop>web> then delete the item in the list, not "My Current Home Page."

    I think that should do it..
     
  3. russ

    russ Guest

    Customize desktop only gives me a general tab to change icons for my computer, recycle bin etc and a checkbox to clean the desktop. Theres no tab for web.
     
  4. Jewelzz

    Jewelzz OSNN Godlike Veteran

    Messages:
    10,977
    Location:
    California
    Isn't it right click on the taskbar?
     
  5. russ

    russ Guest

    No. Right clicking the taskbar did not help either. That only provided options for the task bar itself or start menu.
     
  6. xsivforce

    xsivforce Prodigal Son Folding Team

    Messages:
    8,547
    Location:
    Texas, USA
    I beleive that rodneyck is correct in the post before.

    Make sure nothing in there is checked.
     
  7. russ

    russ Guest

    Again, I tried right clicking the desktop > properties > customize and all I get is a general tab to show desktop icons (My computer, recylce, my documents), change the icon or clean the desktop every 30 days. There is no web tab, no web content or anything to uncheck. I did do some tweaking in the admin tools (services) a few weeks ago - could that have removed a tab that should be there?
     
  8. xsivforce

    xsivforce Prodigal Son Folding Team

    Messages:
    8,547
    Location:
    Texas, USA
    Oh, I should have read more carefuly. That is odd. I don't have an answer for you but, someone here will.
     
  9. xsivforce

    xsivforce Prodigal Son Folding Team

    Messages:
    8,547
    Location:
    Texas, USA
    I'm back...read about it here
     
  10. russ

    russ Guest

    This MS article was for WIN 98 but it appears to the same type of problem for XP. Anyway, I opened TweakUI but the entry - Click the Internet Explorer 4 tab, click the Active Desktop Enabled check box to select it, and then click OK - was not there.

    It appears I may have to make a manual registry entry to correct this. Any idea where I look and what settings I use?
     
  11. allan

    allan Guest

    Start / Run / Regedit
    Navigat to: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    Look for (or create) the DWord Value: NoActiveDesktop
    Settings: 0 = disable restriction, 1 = enable restriction
     
  12. russ

    russ Guest

    I located it. but before I add a DWord value, there already is an entry for NoActiveDesktop REG_Binary 01 00 00 00. Should I try changing this to 00 00 00 00 or leave it as is and add NoActiveDestop REG_DWord 01 00 00 00? Remember my goal is to regain the Web tab in properties so I can enable or disable active desktop.
     
  13. allan

    allan Guest

    Didn't we just solve this on the site where I moderate?
     
  14. russ

    russ Guest

    Yes we did. That post was made here shortly before I returned and received your suggestion.
     
  15. xsivforce

    xsivforce Prodigal Son Folding Team

    Messages:
    8,547
    Location:
    Texas, USA
    People on this site might want to know how this was solved in case it happens to them.
     
  16. allan

    allan Guest

    Sorry - The registry entry I listed above is the correct solution.
     
  17. russ

    russ Guest

    I received two suggestions that were helpful

    Enable or Disable Active Desktop

    Go to Start > Run > Regedit
    Navigate to: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    Look for (or create) the DWord Value: NoActiveDesktop
    Settings: 0 = disable restriction, 1 = enable restriction
    The value of one ENABLES the NO ACTIVE DESKTOP setting (which DISables active desktop).

    or

    You can do this on XP Pro with group policy
    User Configuration\Administrative Templates\Desktop\Active Desktop folder. By default, active desktop is always on. I tried disabling it the group policy, but it did not produce the shortcut on the right click context menu. I have the web tab available either way.

    Create a new DWORD value named "NoActiveDesktop
    For user specific settings use:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersionPolicies\Explorer]

    For computer specific settings use:
    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]

    Value Name: NoActiveDesktop
    Data Type: REG_DWORD (DWORD Value)
    Value Data: (0 = disable restriction, 1 = enable restriction
     
  18. russ

    russ Guest

    Here are the solutions I received:

    Enable or Disable Active Desktop

    Go to Start > Run > Regedit
    Navigate to: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    Look for (or create) the DWord Value: NoActiveDesktop
    Settings: 0 = disable restriction, 1 = enable restriction
    The value of one ENABLES the NO ACTIVE DESKTOP setting (which DISables active desktop).


    You can do this on XP Pro with group policy
    User Configuration\Administrative Templates\Desktop\Active Desktop folder. By default, active desktop is always on. I tried disabling it the group policy, but it did not produce the shortcut on the right click context menu. I have the web tab available either way.

    Create a new DWORD value named "NoActiveDesktop
    For user specific settings use:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersionPolicies\Explorer]

    For computer specific settings use:
    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]

    Value Name: NoActiveDesktop
    Data Type: REG_DWORD (DWORD Value)
    Value Data: (0 = disable restriction, 1 = enable restriction