"Device needed to boot system" errors

Discussion in 'Windows Desktop Systems' started by JeremyT, Apr 22, 2002.

  1. JeremyT

    JeremyT Guest

    I have wake on LAN shutoff. Completely. And remote assistance just in case...

    Problem: Whenever I try to uninstall my NIC I get an error saying that the "device is needed to boot system". I tried using safe mode and still no luck.

    Also, when I try to install my new NIC it won't install right. Always says that the "files cannot be found" even though I have a disk with the drivers.

    I have tried to manually put the files where they need to be, to install from my hard drive, but still nothing. I've repaired my XP install already, ran scandisk etc...

    I've switched PCI slots thinking maybe it was that, but anything else I use works fine (modem, DV card).

    I've booted in safe mode to see if I had multiple instances of the same card/drivers installed, but that just takes me back to the first problem. I do see my old NIC and also my new one however, just can't do anything about it...

    Thanks in advance
    -JeremT
     
  2. redsolar

    redsolar Guest

    Try to remove the old NIC without uninstalling it from device manager
    The problem most likely lies in the driver, which starts in the boot sequence of the PC. So try simply removing the NIC from the pc, and installing the new one. You can try to add an old NIC later, if you need it.
     
  3. JeremyT

    JeremyT Guest

    Already tried that, it has a problem when XP tries to install drivers when it detects new hardware.
     
  4. redsolar

    redsolar Guest

    Souns kinda lame, but do you install drivers manually? ie do you set the path yourself for the new NIC drivers?
     
  5. JeremyT

    JeremyT Guest

    No I never install drivers myself, but I just wanted to try it this time just to see if that was a problem.
     
  6. JeremyT

    JeremyT Guest

    I ended up just reformatting the computer and reinstalling XP. As expected it solved the problem, I just hope it doesn't happen again....