COM Surrogate has stopped working

Discussion in 'Windows Desktop Systems' started by sean.ferguson, Feb 27, 2007.

  1. sean.ferguson

    sean.ferguson Moderator Folding Team

    Messages:
    1,693
    Location:
    Fife; Scotland
    Had a little quick search and noticed that no results came up.

    For future reference, there appears to be a bug present in many installs of Vista that when you open a folder containing a video file the above message "COM Surrogate has stopped working" is displayed. (see attached)

    This is part of the Vista system for making thumbnails of your video files. You can fix this by going into your folder view options and checking the box next to "Always show icons, never thumbnails" (See attached)

    Hope this helps some people. :)
     

    Attached Files:

  2. NetRyder

    NetRyder Tech Junkie Folding Team

    Messages:
    13,256
    Location:
    New York City
    This is actually caused by incompatibilities with certain applications. Nero is one very common example (except the latest version, which is Vista-compatible).

    Rather than turning off thumbnails, I would suggest looking for updates to incompatible apps and installing them to fix the problem. :)
     
  3. sean.ferguson

    sean.ferguson Moderator Folding Team

    Messages:
    1,693
    Location:
    Fife; Scotland
    That would work too! I think I better check my version of nero :)
     
  4. Electronic Punk

    Electronic Punk Administrator Staff Member Political User Folding Team

    Messages:
    18,590
    Location:
    Copenhagen, Denmark
    I recently read the other way around Net, its more to do with the poor routine in Windows for making the thumbnails.

    I recently reinstalled both DivX and Nero and neither changed any ofthe relevent parts of the iwould have expected, however it seems the Nero mpeg4 codec has taken over and that really doesn't like the thumbnail creation business - it either won't load them or it just shows them as black (possibly the first frame) whereas when divx is in control or where the same process has to be done via WMV it will pick an interesting frame at least (by some means or another)
     
  5. NetRyder

    NetRyder Tech Junkie Folding Team

    Messages:
    13,256
    Location:
    New York City
    Certainly a possibility. I didn't mean that ISVs are the only ones at fault here. What I meant was that this particular error is caused by incompatibilities between certain apps and Vista, which is why it doesn't occur on a clean setup with nothing else installed.

    Once you pinpoint the cause, it's not hard to fix though. Just download an updated version, or find another Vista-compatible alternative. :)
     
  6. Electronic Punk

    Electronic Punk Administrator Staff Member Political User Folding Team

    Messages:
    18,590
    Location:
    Copenhagen, Denmark
    Might work on unregistering the Nero filter rather than renaming it to *.bak as read elsewhere as Nero Vision really didn't like me doing that.
     
  7. ScottFern

    ScottFern IT guy

    Messages:
    48
    Location:
    Chicago
    This has occurred on my Vista Ultimate box and I do not have Nero installed. It now makes sense that this error occurred when I had a folder open with lots of videos in it obviously. Hmm, I had Disk Keeper 2007 open? But that's supposed to be compatible with Vista?

    Unrelated, I think there is an incompatibility with WinAMP and my XtremeMusic driver because WinAMP acts very laggy in Vista. Trillian seems to function just fine.
     
  8. vertigo

    vertigo OSNN Senior Addict

    Messages:
    330