CHKDSK at Startup?

Discussion in 'Windows Desktop Systems' started by Hoyd, Jul 22, 2002.

  1. Hoyd

    Hoyd Guest

    Hi,

    For some reason, whenever I need to restart my computer, it says that CHKDSK has been scheduled. This is fine, except after it finished the check, the computer reboots as it should, but then freezes right after the Windows logo screen.

    So, then I need to hit the restart button and I get the message about Windows being improperly shut down and I choose Start Windows Normally and it works. But, then next time I restart, I have to do this same cycle all over again. Is there any way that I can check to see whey CHKDSK is scheduled at next startup and tell it not to do it.

    Thanks in advance for any suggestions!

    Hoyd
     
  2. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Messages:
    5,920
    Location:
    Melbourne Australia
    If you are not using it you could convert to NTFS file system.
     
  3. Hoyd

    Hoyd Guest

    I am using NTFS file system...

    Hoyd
     
  4. NetRyder

    NetRyder Tech Junkie Folding Team

    Messages:
    13,256
    Location:
    New York City
    CHKNTFS

    Start>Run>cmd
    Type chkntfs /?

    See what you can do from there ...
    Good luck! :)
     
  5. allan

    allan Guest

    Try running chkdsk /f on the drive.
     
  6. Hoyd

    Hoyd Guest

    OK,

    I've done both of those things.

    When I type chkntfs c:
    It says that chkdsk has been scheduled to run manually on next reboot on volume c:.

    When I type chkdsk /f
    It says chkdsk cannot run because the volume is in use by another process. Would you like to schedule this volume to be checked the next time the system starts (y/n) - I choose N since it's been checking everytime my system starts and that's the problem.

    Any other advice... what does it mean when it says : chkdsk will run if the drive is dirty - what does it mean by dirty exactly?

    Thanks again.
     
  7. allan

    allan Guest

    You have to answer YES. Chkdsk /f will not only run check disk, but will repair errors.
     
  8. Hoyd

    Hoyd Guest

    Right... I understand that... but from my original post, it is running at startup already, not finding any errors, rebooting, freezing, and then making me reboot again... I'm trying to stop that cycle...
     
  9. Shamus MacNoob

    Shamus MacNoob Moderator Political User

    Messages:
    4,199
    Location:
    L'Ile Perrot Quebec
    updates

    Got all your windows updates think I saw one related to that a way's back
     
  10. Shamus MacNoob

    Shamus MacNoob Moderator Political User

    Messages:
    4,199
    Location:
    L'Ile Perrot Quebec
    or this

    You might find an 'autocheck' entry (value) that can be deleted at: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\BootExecute
     
  11. Pastorn

    Pastorn Guest

    1. Delete the key: "BootExecute", which is located in: "HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager" (Just as Kermit said) :)

    2. Reboot

    3. run "chkdsk /f" in cmd

    4. Reboot
     
  12. allan

    allan Guest

    Okay, let's disable auto-scan:

    Start - Run - Regedit and navigate to:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ControlSession Manager

    Then look for or create the Value: AutoChkTimeOut
    Data Type: DWORD Value
    Set the value data as follows: Time in Seconds or 0 to disable
     
  13. Hoyd

    Hoyd Guest

    Thanks everyone for all your help.

    In the end, I think it might have been that my harddrive was too full... don't really know why, but I was down to only about 300MB free so I burnt off some data and I'm up to over a gig free now and it doesn't do it anymore.

    Does this make sense? Or is it just a conicidence that it's suddenly fixed?