cant run 16 bit Windows program

Discussion in 'Windows Desktop Systems' started by lullabytes, Jul 17, 2002.

  1. lullabytes

    lullabytes Guest

    I am unable to install some programs on my XP machine .. two in particular are Yahoo Instant Messenger & AdShield. I am attaching a screen shot of the error message. With some programs I have been able to work around the problem by opening the .exe file with winzip & extracting/installing that route. But in the case of these programs, nothing works.

    I know from surfing other boards, forums, MS knowledge base etc... that others have the same problem & noone seems to know the answer. Any chance someone here can help?

    I am running a PIIII, 512mg RAM ... brand new machine.
  2. G-Lizard86

    G-Lizard86 Guest

    It could be me but xp only runs 32 bit programs...
  3. Crucial

    Crucial Guest

    Not promising anything but ... you could try putting the install files in a directory that a 16Bit program might recognise.

    Think back to windows 3.11 etc, you couldn't have directories with spaces in them etc. Try making a c:\shortDir (max of 8 chars) and running the program or install from there.

    Again, not promising anything, but its worth a try if you 'really' want to run 16Bit stuff.
  4. lullabytes

    lullabytes Guest

    16 bit programs & XP

    Why would I "want to run 16 bit programs" you ask? Ummm....its not a conscious choice - I am simply trying to download/install Yahoo IM and the AdShield program that dealer installed earlier in the is on XP as well & recommended it.

    Sooo, back to my original question ...... any other XP users having problems installing Yahoo IM and/or AdShield as I am?
  5. G-Lizard86

    G-Lizard86 Guest

    Maybe you just downloaded the wrong files?
  6. Crucial

    Crucial Guest

    Did you try installing them from c:\smallDir ? - still have the same problem then?
  7. velocttx

    velocttx Guest

    I've had the same problem trying to install the latest yahoo messenger beta, the latest stable installs fine but when I try the beta by opening it I get the same error code as lullabytes or if i download it to my hard drive and i try to install it i get "unable to initialize install". Only thing I can think off is that on the beta page XP is not listed as one of the platforms, maybe is not able to run in XP yet. :(
  8. Hammer

    Hammer Guest

    I had the same problem with some other programs .I then noticed that in Tweak-XP there is an option in : system + file tweaks --> windows tweaks ---> miscellaneous tweaks to run a 16 bit application in a separate virtual machine (vdm).

    By ticking this box it has solved my problems so perhaps you shoul'd give it a try .

    Hope it helps .
  9. eNuffSaid

    eNuffSaid Guest

    It seems to me, after you double click the setup.exe, it extracts itself to the temp directory shown in your screenshot. After that it should give control the the actual installer located in that very temp directory, however it seems, it cannot find the right file.

    Try cleaning up your temp directory by deleting everything in it, and try again. If that doesn't work, try locating the setup.exe (as shown in the screenshot) and double clicking it there.

    You could also try moving the contents of that directory to one closer to the root of your C:\ drive (eg. C:\yahoo), and then double click the setup.exe again.

    Kind regards,
    Willem Moolenaar
  10. tinomen

    tinomen Guest

    16 Bit

    Not sure if this will help or not, I don't use either of the programs named or anything 16 bit that I can think of, but another possible work-around would be to try to run it as a win98 app. This can be done (if I recall correctly --- I'm not at home and no XP at work) by right clicking on the install file and in the advanced properties select run in Windows 98 compatibility mode.

    Again, I make no promises, but it worked for me when install continually failed for zMUD. Difference is, zMUD is a 32 bit app....
  11. Lestat21

    Lestat21 Guest

    If it is the 16 bit subsystem error then you need to locate these file and edit the command line

    In Windows XP, Config.nt contains the following

    commands by default:
    dos=high, umb
    Autoexec.nt contains the following commands by default:
    @echo off
    lh %SystemRoot%\system32\mscdexnt.exe
    lh %SystemRoot%\system32\redir
    lh %SystemRoot%\system32\dosx
    SET BLASTER=A220 I5 D1 P330 T3

    I had this same problem I couldn't install anything that was 16 bit but this fix it.
  12. Lestat21

    Lestat21 Guest

    @echo off
    lh %SystemRoot%\system32\mscdexnt.exe
    lh %SystemRoot%\system32\redir
    lh %SystemRoot%\system32\dosx
    SET BLASTER=A220 I5 D1 P330 T3