Can't get through to my server from external but can if I'm internal

Discussion in 'Windows Desktop Systems' started by pokerblogger, Jun 26, 2006.

  1. pokerblogger

    pokerblogger OSNN Addict Folding Team

    Messages:
    125
    Location:
    Portland
    I set my linksys router to have port forwarding to the SSH port but when I try connecting from an external network I get a timeout. If I'm connected to my network internally and SSH the port forwarding goes to the correct server and I'm able to login.

    Externally, SSH times out and so does ping - Traceroute makes it as far as my local Comcast . . .

    Any ideas?
     
  2. kcnychief

    kcnychief █▄█ ▀█▄ █ Political User Folding Team

    Messages:
    16,948
    Location:
    Massachusetts
    If you can do it internally but not externally, something has to be configured incorrectly on the router I would wreckon.

    Try RDP to see if you can get through?
     
  3. pokerblogger

    pokerblogger OSNN Addict Folding Team

    Messages:
    125
    Location:
    Portland
    Nope, won't even ping the IP.
     
  4. kcnychief

    kcnychief █▄█ ▀█▄ █ Political User Folding Team

    Messages:
    16,948
    Location:
    Massachusetts
    Well a ping isn't a true test, as you probably have ICMP blocked.

    I still say double-check your firewall though, what is the make/model of it? Post a screenshot of your port forwarding screen?
     
    pokerblogger likes this.
  5. pokerblogger

    pokerblogger OSNN Addict Folding Team

    Messages:
    125
    Location:
    Portland
    Image of port forwarding screen attached . . .
     

    Attached Files:

  6. VenomXt

    VenomXt Blame me for the RAZR's Folding Team

    Messages:
    3,453
    Location:
    Houston, Texas
    did you ip address change on the server?
     
    pokerblogger likes this.
  7. pokerblogger

    pokerblogger OSNN Addict Folding Team

    Messages:
    125
    Location:
    Portland
    I noticed I had "Block WAN Request" enabled in the "filtering" tab, this may have been the issue. I'll have to try externally but I think this may have been the issue. Thank you everyone for the help.

    Nope, the server has a static IP assigned.

    posts merged
     
    Last edited by a moderator: Jun 27, 2006
  8. pokerblogger

    pokerblogger OSNN Addict Folding Team

    Messages:
    125
    Location:
    Portland
    Ok, so I've tried everything now, reset the router to factory defaults, followed instructions for enabling ssh step by step and nothing.

    Should I buy a new router? Could it be the Debian box? Should I just nuke that and install FreeBSD? It seems like it isn't the Linux box if I'm able to ssh in while inside my network . . . but that also means the linksys router is forwarding right? What the hell could be causing this?
     
  9. kcnychief

    kcnychief █▄█ ▀█▄ █ Political User Folding Team

    Messages:
    16,948
    Location:
    Massachusetts
    I'm sorry for not suggesting this earlier, but it could be possible your ISP is blocking the ports necessary to access it. It could be a longshot, depending on your provider and config, but it's something you should try. SSH isn't illegal, so there is no harm in contacting your ISP and asking them if they block the port. If they are, they might even unblock it for you.

    Most ISPs will block ports by default, such as ports required for SMTP/POP3 because they don't want people running e-mail servers. Also common ports to block are those necessary for VPN connections. All viable purposes, but blocked for the safety of the consumers for the most part. In different instances, I have had all ports opened successfully by contacting my ISP and providing due cause.

    Furthermore, it's not the OS because everything works fine internally. I don't think it's the router because you reset to defaults and that is essentially the "loosest" config.
     
  10. pokerblogger

    pokerblogger OSNN Addict Folding Team

    Messages:
    125
    Location:
    Portland
    OK, thank you for the assurance on the Debian setup :)

    I called COMCAST and they said that "all ports are open"

    I then proceeded to reset my router again.

    I disabled "Block WAN" on the router.

    I setup port forwarding to forward port 22 to port 22 on the local IP of my server.

    I ran a test on grc.com which said that port 22 was in "stealth" mode. Could this be the problem?
     
  11. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    Sounds like it isn't listening on 22. Is ssh listening on port 22 on the debian box? I would do a nmap [port] scan inside your LAN and see what is open on the debian PC, just to make it is in fact listing on port 22.

    If comcast is in fact blocking ssh, just because lvl1 tech said they aren't doesn't really mean anything. ;) Try forwarding port 2222 to port 22 and connect using ssh username@hostname.com:2222
     
    pokerblogger likes this.
  12. pokerblogger

    pokerblogger OSNN Addict Folding Team

    Messages:
    125
    Location:
    Portland
    Ok - I got it :)

    Wound up being the Linux box being misconfigured. Thank you everyone for the help!