can't ftp

Discussion in 'Windows Desktop Systems' started by Tuffgong4, Aug 21, 2004.

  1. Tuffgong4

    Tuffgong4 The Donger Need Food!!!! Political User

    Messages:
    2,465
    Location:
    Chicago
    I'm behind a dlink di-624 rev C router and windows SP2 firewall...have tried all I can to get the ftp to work but I keep doing something wrong...

    please help if you
     
  2. NetRyder

    NetRyder Tech Junkie Folding Team

    Messages:
    13,256
    Location:
    New York City
    Have you tried enabling passive mode?
     
  3. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    and forwarding the passive range of ports to your ftp server? Does your ISP allow FTP servers?
     
    Tuffgong4 likes this.
  4. PseudoKiller

    PseudoKiller Zug Zug

    Messages:
    3,858
    Location:
    Ice Crown Citadel
    whats the error you get when trying to connect to a site?? and do you have the SP2 firewall enabled and are you allowing ftp to pass thru?? also what ftp program are you using??

    A little more info would be more helpful.
     
  5. Tuffgong4

    Tuffgong4 The Donger Need Food!!!! Political User

    Messages:
    2,465
    Location:
    Chicago
    ok I have no idea what passive mode is...what I'm trying to do is get to access my webhosting provider through ftp...I am a comcast subscriber and my webhost is 1and1

    I am using Filezilla 2.2.8a and the error I get is
    Error: Timeout detected!
    Error: Could not retrieve directory listing

    if more info is needed I can provide...I have also followed my routers instructions to ftp and enabling it through the firewall in the router
     
  6. PseudoKiller

    PseudoKiller Zug Zug

    Messages:
    3,858
    Location:
    Ice Crown Citadel
    2 things... 1 either you do not have the port forward going to the correct machine IP and/or 2 you may want to turn off PASV mode. If you dont know what the is check out the help file in Filezilla. I am not familiar with that program.
     
    Tuffgong4 likes this.
  7. NetRyder

    NetRyder Tech Junkie Folding Team

    Messages:
    13,256
    Location:
    New York City
    I assume you've created a profile for your FTP account in FileZilla's site manager. To enable passive mode:

    File>Site Manager
    Select the FTP account
    Click the "Advanced" button
    Check the "Use passive mode" box

    If that doesn't work, try using SFTP. I've found that it works without a problem with 1and1's servers, and it's more secure than using regular FTP. To do that, go back to the Site Manager window, select the FTP account, and change the server type to "SFTP using SSH2"

    Hope that works. [​IMG]
     
  8. Tuffgong4

    Tuffgong4 The Donger Need Food!!!! Political User

    Messages:
    2,465
    Location:
    Chicago
    ok I checked the set up of the router and I have the correct ip set up for it...I went into the settings of filezilla and set it up for only 2 ports (the same as my router) and enabled passive mode and it went through with no problems...thanks to all I appreciate the help
     
  9. NetRyder

    NetRyder Tech Junkie Folding Team

    Messages:
    13,256
    Location:
    New York City
    Glad it worked out. [​IMG]
     
  10. Tuffgong4

    Tuffgong4 The Donger Need Food!!!! Political User

    Messages:
    2,465
    Location:
    Chicago
    ha...I can't give you anymore rep points netryder...you must have helped me with something else recently!
     
  11. NetRyder

    NetRyder Tech Junkie Folding Team

    Messages:
    13,256
    Location:
    New York City
    Don't worry about it. [​IMG]
     
  12. dreamliner77

    dreamliner77 The Analog Kid

    Messages:
    4,702
    Location:
    Red Sox Nation
    Just a heads up: after a lot of frustrations with 1and1, I have learned that 1) you must use passive mode and 2) give a large number for time between retries and max out the number of retries.
     
  13. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    If you only forwarded two ports for passive mode the server can only handle two connections at one time (which in practise means one client since many clients use one connection for listing and one for file transfer).