Cannot get valid IP address on my NIC.

Discussion in 'General Hardware' started by rs008f, Aug 7, 2002.

  1. rs008f

    rs008f Guest

    I have a cable modem connection and cannot seem to get a valid IP address. This occured after a corrupt /winnt/system32/config/system error came up which I solved it by replacing the file with a default one. Now I cannot get a valid IP address when the NIC is connected to my cable modem. My address is like 169.254.xx.xx. I have Windows 98 on a second partition and the NIC/cable modem works fine, I can get a valid IP address. How can I fix this? I cannot get a valid IP for my NIC under windows xp ever since I replace the old system file with the default one. There must be something in the old system file that is missing in the new system file. Any ideas would be great. I tried repairing the connection but it failed too. It's not hardware, it's more of a windows xp problem. Also what is the equivalent of the command <b>nslookup</b> in windows xp for windows 98? I'm goin to try to put in the IP manually in winxp but cannot find the address of the DNS server under windows 98. WHat's the command line? In windows xp I used nslookup.
  2. Zedric

    Zedric NTFS Guru Folding Team

    Two suggestions:
    1. Try a System Restore to before the error occured.
    2. Do a Repair of your WinXP installation. This can be done if you boot from the XP CD.
  3. JJB6486

    JJB6486 Retired Mod Political User

    West Lafayette, IN, USA
    Start->Run "ipconfig /release"
    Start->Run "ipconfig /renew"

  4. sarkastro

    sarkastro Guest

    might also try uninstalling your NIC, and reinstalling it. Also, there is no equivalent to nslookup in 9x. You should be able to see your DNS servers by hitting more info on winipcfg in 9x. There are also many 3rd party programs as well as websites that provide nslookup functionality
  5. Bluecat

    Bluecat Guest

    In Win98, Start > Run > winipcfg
    Once in there, you can grab all the DNS info.

    Apologies, I missed that you mentioned winipcfg Sarkastro. My bad.
  6. XPos

    XPos OSNN Addict

    Had the same problems using Cox internet service. They told me to unplug the modem and shut down the system, wait 5 min. and plug it back and restart your computer. Has something to do with the IP address not establishing correctly.
  7. XPos

    XPos OSNN Addict

    Forgot that Cox also had me open a command prompt and run ipconfig /release and then ipconfig /renew.

    Hope this helps