Boot up wrong OS

Discussion in 'Windows Desktop Systems' started by napalmnthemorning, Jan 7, 2004.

  1. napalmnthemorning

    napalmnthemorning Moderator

    Messages:
    721
    Location:
    OREGON
    I installed a beta version of Longhorn a few days ago into a seperate primary partitian I created with acronis. After I messed with it a few hours I decided to uninstall. The problem I have now is when my pc boots up, it goes right into Longhorn OS which isn't there any more, and I get a messge about the ntoskrdnl.exe is missing in WINDOWS root>system32? I checked in this file and I do have it. What I've been doing is when I reboot I have to hit my arrow button real fast while I'm booting up so it cathces XP Pro option on the boot screen. The other two options are "XP Professional orignal", and "Longhorn" I opened up boot notepad in my drive directory to edit and it shows the following:

    [boot loader]
    timeout=0
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /KERNEL=kernel1.exe
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional (Original)" /fastdetect

    I hope I'm explaining myself here.
     
  2. blinden

    blinden OSNN Senior Addict

    Messages:
    268
    Location:
    Pittsburgh, Pa, USA
    well, first, if you edit the timeout to a number, you should have a few seconds to pick your OS (whatever number you put there) I don't know why it would go to boot to an OS that isn't even listed there, but I dont' know anything about what that other OS is doing (this is why you shouldn't use beta stuff)
     
  3. napalmnthemorning

    napalmnthemorning Moderator

    Messages:
    721
    Location:
    OREGON
    Good point on the beta version. Real sluggish so far but some real cool features. I already changed the number value with no luck.
     
  4. Cirrus

    Cirrus OSNN One Post Wonder

    Messages:
    4
    Location:
    Amsterdam, The Netherlands
    Perhaps this will work:

    [boot loader]
    timeout=10
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional " /fastdetect
     
  5. napalmnthemorning

    napalmnthemorning Moderator

    Messages:
    721
    Location:
    OREGON
    Thanks Cirrus. I'll give it a try.
    -Anyway to delete the Longhorn Operating System option on the boot screen since I have already uninstalled it.
     
  6. yoyo

    yoyo _________________

    Messages:
    1,557
    So at the moment you have one installation of Windows XP Pro, installed on the first partition, on the first harddrive, in a folder named WINDOWS?
    The default boot.ini should look like this:

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect


    The entry containing the /KERNEL switch you have there was/is used to boot using a different boot screen. Don't know if you still need this one.
     
  7. napalmnthemorning

    napalmnthemorning Moderator

    Messages:
    721
    Location:
    OREGON
    Boot BXP file in my G:\ drive (where my XP Pro OS is located) it says this

    [boot loader]
    timeout=5
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /KERNEL=kernel1.exe
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional (Original)" /fastdetect

    The only file in WINDOWS is a file called Bootstat with this inside. "   " and this is it!
     
  8. yoyo

    yoyo _________________

    Messages:
    1,557
    A boot.bxp file is as far as I know a backup file created by BootXP, not a file used to start Windows.

    The boot.ini isn't in the Windows folder. It is in the root of the SystemDrive, that usually is the C: drive, even if XP is installed in D: or G: .
    Just look where the other boot files are - ntldr and ntdetect.com (all hidden and system files).

    Or open msconfig to the boot.ini tab and click the "Check All Boot Paths" button.

    Or Windows key + Pause - Advanced - Startup and Recovery - Settings - System Startup > change the settings there or click the Edit button to open the boot.ini in Notepad.

    If you are not sure what to edit post the content here together with a description of your drive configuration.