Black & White on XP

Discussion in 'PC Gaming' started by Daedalus, Jan 14, 2003.

  1. Daedalus

    Daedalus Guest

    I'm having trouble running Black & White on Windows XP. After clicking the shortcut or the 'Play' button on the CD's autorun menu, it runs it's safedisc checks, then arrives back at the windows desktop. I've tried this without/with the patches, and this still happens. It worked fine on 98/ME but with XP it fails to run.

    Does anyone have any success running this game on XP? if so, how did you achieve this?

    Thankyou in advance
     
  2. Octopus

    Octopus Moderator

    Messages:
    1,200
    try compability mode, right click on the exe file and choose compability
     
  3. sboulema

    sboulema Moderator

    Messages:
    2,846
    Location:
    Amstelveen, The Netherlands
    i have run b&w several times on xp, but i needed to reinstal the game and now i get an error bout runblack.exe
     
  4. Guybrush

    Guybrush Village Idiot

    Messages:
    174
    Location:
    Skidby-East Yorkshire
    Safedisk!

    I had the same problem with Grand Prix 4 and windows XP. Apparently this is a well known problem

    Amazingly though after I installed the service Pack 1 for XP the game runs no problem now.

    There was a fix somewhere but sorry I cannot remember where I saw this .

    Sorry I cannot be of any help but this was my fix, funny as it may sound!
     
  5. Guybrush

    Guybrush Village Idiot

    Messages:
    174
    Location:
    Skidby-East Yorkshire
    Me again!

    I think the patch also was on the Macrovision site come to think of it now.
     
  6. Daedalus

    Daedalus Guest

    erm...shouldnt post cracks/serials/warez links here, remove it before a mod sees it.

    That isnt a solution to my problem as I shouldnt need to use a crack to get my game running, it is the genuine disc, and should run on XP
     
  7. sboulema

    sboulema Moderator

    Messages:
    2,846
    Location:
    Amstelveen, The Netherlands
  8. Daedalus

    Daedalus Guest

    Hmm.. that KB link didnt have anything to do with my problem, but thanx anyway..

    it's not the video thats causing the crash, as I can run mafia without any problems on XP (also uses Indeo codec for intro video). I'm sure it's a safedisc issue, but the add-on pack 'Creature Isle' works fine, but it's useless until I get myself a creature set up in the original.
     
  9. Guybrush

    Guybrush Village Idiot

    Messages:
    174
    Location:
    Skidby-East Yorkshire
    Safedisk XP Patch

    After searching through my backup disks for some files formyself I came across this file for safedisk which is meant to cure the XP Problem - don't worry it is not dodgy!!!

    Please see attachment

    I hope this works for you;)
     
  10. Guybrush

    Guybrush Village Idiot

    Messages:
    174
    Location:
    Skidby-East Yorkshire
    Safedisk file

    Understandably I am unable to send this file through this site so if you still want the file e-mail me at:

    chrisd@theavenue.karoo.co.uk

    I will then send it to you

    Hope this helps;)