BF1942 Wont Run

Discussion in 'PC Gaming' started by _DM_, Aug 15, 2003.

  1. _DM_

    _DM_ OSNN Senior Addict

    Messages:
    475
    I installed the game, then I click run, then it shows the BF1942 spalsh screen and then it makes this error sound and goes back to desktop. There is no error messages. Wtf is going on? How do I fix this?
     
  2. 82ross

    82ross Guest

    Try updating it to the latest version.

    Then goto the settings folder and find a file called VideoDefault.con or something like that.

    In that there will be a line saying render.AllowAllRefreshRates 0 or something similar. Change the 0 to 1 and save it. See if it works now.

    The names i just guessed cos its been a while since i done it myself but you should be albe to find the things i mean easily.
     
  3. _DM_

    _DM_ OSNN Senior Addict

    Messages:
    475
    Ya I installed the latest patch, and i changed the render.AllowAllRefreshRates 0 to 1. It still doesnt run. Is it probably my video card? I have a radeon 9700 pro catalyst 3.6 .
     
  4. 82ross

    82ross Guest

    Hmm, try running it not in full screen. Then you might be able to see if an error box pops up for a second.
     
  5. Tiesto

    Tiesto OSNN Addict

    Messages:
    112
    So many people have problems with BF1942. It is most likely a video card problem, if youve got an ATI card make sure you have the latest NON BETA drivers.
     
  6. _DM_

    _DM_ OSNN Senior Addict

    Messages:
    475
    Thnxs for helpin. But I solved it. For everyone out there that is having the same problem heres a solution. I downloaded ATi Refresh Rate Fixer. And I i saw that the 800x600 resolution was using a 75 hz. so i lowered it to 56 hz. I retsrated the computer and BF was finally working.
     
  7. C.Y.A.

    C.Y.A. Guest

    56 hz yuck that must be choppy i've got bf1942 running at 1024x768 at 100hz
     
  8. _DM_

    _DM_ OSNN Senior Addict

    Messages:
    475
    is it possible to use 1024x768 at 100hz with a 15 inch?
     
  9. Gus K

    Gus K NTFS abuser

    Messages:
    380
    Location:
    USA
    Depends on your monitor. No real reason for it though. 75hz is fine for a 15in, for a 17 or 19in 85hz is good.

    If you are running XP with sp1 you can go into dxdiag more help and set you refresh rate there (override). Also set it for your desktop. Any decent newer monitor can always handle 75 and 85hz at 1024 X 768. Unfortunately that only works for D3D, not for OpenGL.
     
  10. adamg

    adamg Guest

    If you wanna set your refresh rate for Direct3D/OpenGL then use RefreshLock (do a google search). Automatically finds your monitor settings (if you have a monitor defined) and has heaps of options.