BF 1942 mouse lags

Discussion in 'PC Gaming' started by Petros, Dec 23, 2003.

  1. Petros

    Petros Thief IV

    Messages:
    3,038
    Location:
    Pacific Northwest
    When playing online games of BF1942, my mouse seems to follow all the movements I make, but slightly slower than when I actually move it. This has been a long-standing problem for me in the game that really has robbed me of enjoying plane battles and sniping, not to mention making close-quarters melees almost impossible to win.

    Is there a setting to fix this, or am I screwed? I'm on a cable connection, and none of my other online FPS games have this problem.
     
  2. 50cal

    50cal Guest

    what kinda a mouse are you using? ball type , optical sensor, or cordless?;)
     
  3. LeeJend

    LeeJend Moderator

    Messages:
    5,291
    Location:
    Fort Worth, TX
    Yes, if it's the mouse response speed. You can adjust the mouse speed for each type of game function in BF1942 (ground, air, sea, etc each has its own mouse gain).

    Its under the Options Controls in the menu system. Mouse gain will be off to the right.

    If its mouse lag, like delay through a USB mouse port then there was another thread in the last couple of months that said how to improve USB mouse responsiveness. Can't remember the details.
     
  4. Petros

    Petros Thief IV

    Messages:
    3,038
    Location:
    Pacific Northwest
    My system specs are in my profile, but it's a Logitech MX 500 (an optical mouse). It works fine on other games, just not BF1942 for some reason. It's not slow (it moves as fast as I move my mouse), it's just that every movement is delayed.
     
  5. LeeJend

    LeeJend Moderator

    Messages:
    5,291
    Location:
    Fort Worth, TX
    I'm using a logitech optical mouse also and see no mouse related delays in BF1942. Mine is plugged into the PS2 port.

    Have you gotten the most recent logitech driver package?
    MW978enu.exe

    There is a mouse "report rate setting under the logitech utility software. (control panel-mouse-motion tab at bottom) Make sure thats at a high enough speed mines at 100 and I've seen 125 recommended.