Ati System Cache Problem Heads Up

Discussion in 'Windows Desktop Systems' started by indyjones, Jan 16, 2004.

  1. indyjones

    indyjones Adventurer

    I hope this will be of use to some of you.
    I have been having a problem with my computer which i noticed a few formats ago. That is when i install my drivers and enable "optimise cache for system files" under windows-> system-> advanced...(please refere to image attached) My computer dies a painful death normally resulting in a reformat.
    The errors received are "Disk Write Error" and "Unable to write to #MFT" which locks the pc up.

    This was a large Problem!
    After extensive "googling" (surely a new dictionary word soon :rolleyes: )
    I have found a solution! (Sorry I saved it as a text file so can't remember the direct link but the info was hidden in the depths of the ATI website):-

    "Re: "delayed Write failure" in WIN XP
    Found a fix:

    Data corruption may occur if the Large System Cache feature is enabled in Windows XP. This symptom does not occur on all systems. The key ingredients that lead to this symptom may include:

    System Memory greater than 512 Meg. (1 gigabyte of RAM is common)
    - Large NTFS disk volumes. And multiple large volumes. (60-100 gigabyte hard drives possibly in RAID arrays)
    - AGP graphics with large AGP resource requirements (AGP aperture greater than default)
    - Large file transfers
    This problem occurs when the computer runs out of system page table entries. Windows determines (at boot time) the default number of page table entries to assign, based on the amount of system memory available. The items mentioned above all contribute to increasing the number of page table entires that Windows XP must maintain and in extreme cases the page table entries may be exhausted.

    To avoid this symptom ensure the System Cache option is NOT selected for Memory usage. Use the Programs option.
    - right-click on the My Computer Icon then Properties to open the System Properties dialog box

    - select the Advanced Tab then the Settings button under Performance

    - select the Advanced tab on the Performance options tab

    - in the Memory Usage area, ensure the Programs radio button is selected

    - Apply the changes and select OK

    It may be possible to work around this issue by increasing the value for page table entries, as follows,

    WARNING: Please make a backup copy of your Registry before proceeding. If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Use Registry Editor at your own risk.

    Launch the Registry Editor. Select the Start Button then Run. Type in regedit.exe and select OK.

    Locate the SystemPages value under the following key in the registry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

    Double-click the SystemPages value. The Edit DWORD Value dialog box appears.

    Enter the maximum value (0xFFFFFFFF) , and then click OK.

    Quit Registry Editor.

    NOTE: 0xFFFFFFFF is the safest value however a value greater than the default but less than the maximum may provide better results.

    NOTE: Changing the VALUE from the default may decrease performance by 1-2% . "

    Further research revealed that although you get an "1-2%" performace decrease you do still get an improvement from the "optimised for programs option."

    If you do this remember to change the registry first before you enable "optimised for system cache" :D

    I hope this helps someone it has certainly sorted things my end, hopefully ATI will fix their control centre eventually but until then this fix may work for you. If you are uneasy using regdit I have also attached a .reg file which will make the changes for you.

    Hope this helps

    Indy :)

    Attached Files: