All Of A Sudden my CD reader and CD writer are not being detected

Discussion in 'Windows Desktop Systems' started by RizManery, Jan 30, 2002.

  1. RizManery

    RizManery Guest

    today i tried to use my reader and my PC said that it couldn't initialze the ASPI Manager. Then a couple of minutes later, it couldn't recognize mr writer either. I am really confused and don't know what to do. I tried to open up the DEVICE MANAGER, but i got an error message saying that " MMC.EXE IS NOT A VALID WIN32 APPLICATION". If anyone has any advice for this type of problem, then would appreciate it greatly if you would respond to this message. THANKS!!!!!
     
  2. Tfp

    Tfp Guest

    Your error messages etc.. did not happen to me.

    But I did have the problem of not being able to recognize the reader and dvd.

    My problem was that I had a 40 pin cable, you can get a 80 pin cable at compusa for $30. It worked for me.

    Do you have another computer you can test your cable on??

    This "may" help your problem, no gaurantees.

    Good Luck
     
  3. Qumahlin

    Qumahlin Moderator

    Messages:
    2,006
    you paid 30 bucks for an 80 pin cable?!?!!?!?...CompUSA is such a ripoff...I recommend you find a local mom and pop computer shop in your area...I usually buy 80 pin cables for anywhere between 5-14dollars MAX
     
  4. Tfp

    Tfp Guest

    It was 8pm and I din't have anywhere else to go.
    :)

    Thanks for the future info though.

    I thought it was kinda pricy.
     
  5. Lonman

    Lonman Bleh!

    Messages:
    2,642
    lemme guess, did you install roxio's ezcd by chance?
     
  6. Chernobyl

    Chernobyl Guest

    Can you check in device manager and see if your IDE controllers are fully detected and operational. I have seen instances where only the Host Adapter is present and the 2 IDE channels are not.
    If the channels have a problem or are not present, then your CD drives will not be detected until you sort out your drivers/interrupts or whatever the problem is for the IDE channels.
    Chances are its only a driver problem (they can auto screw up too!).

    I recommend getting the latest IDE drivers for your motherboard. If its a VIA motherboard, install the latest Via 4in1 driver and then install the IDE Miniport driver. If you still have trouble try the IDE Filter driver. Make sure you uninstall the version you have installed first to be safe, if u can.

    If still stuck let me know.
     
  7. Chernobyl

    Chernobyl Guest

    Sorry, I missed your statement that you cant open device manager. Hmm.

    perhaps you can just go straight ahead and install the IDE drivers as suggested. Please get the correct ones for your motherboard (all via boards are the same).