After Re-install of XP Pro, cannot access one of my H.D.D

Discussion in 'Windows Desktop Systems' started by Dragon 185, Dec 5, 2002.

  1. Dragon 185

    Dragon 185 Guest

    Hi, I hope someone can help me.

    After reinstalling Xp Pro on my system I noticed one of my H.D.D is missing, so I went to Disk management plug in. now in this it displays the H.D.D. with no path letter. it shows that there is data on there and the free space remaining. It shows the drive has a FAT32 file system and it's status as Healthy(Active) I just can't get access to it. When I right click on the drive icon the only option it gives me is "Delete Partition" I'm afraid I can't do this as their are some important files on it (yea I know I havn't backed up for a couple of weeks). I tried using the recovery console after booting from the XP Pro cd to see if I can get access to it, but although i got access to it I cannot get access to the directory's on it so cannot transfer the more important files to the other H.D.D on my sys.

    I also Booted up from an MIllenium Boot disk, but it doesn't see any of my H.D.D once boot sequence is finished.

    As a desparate measure I went round to a friends house and connected my H.D.D. to his machime, in the hopes that having Win98 SE might allow it to access the drive, but unfortunately no, it can see it in the device manager it doesn't assign it a path letter and tells me it is an unformatted drive, which I know it is not.

    The drive in question is a Maxtor 40 Gb 7200rpm unit, now it worked fine before I re-installed Win XP pro again.

    Does anyone out there know a way that I can gain acces to the files on that unit and copy them to my other drive. I am desperate, please help if you can. my sys stats are:

    Asus A7V-133 m/b with the latest Via 4 in 1 drivers and Asus 1005a bios
    Athlon TB 1.2 ghz cpu
    512mb pc-133 ram
    2 x Maxtor 40gb 7200rpm H.D.D

    If you want more info, reply here and I'll try to supply it.

    Many thanx

    Dragon 185
     
  2. rettahc

    rettahc Guest

    First off, welcome to the forum.

    Ok now the only thing that I can think of that you have not tried yet is partition magic. other than that I not sure what to do.
     
  3. scotty_02

    scotty_02 Guest

    One possibility is that the partition table got corrupted. If you run fdisk, what does it show you for that disk? If it *is* a lost partition, there are some utilities to do diagnostics and even get back stuff off it (without writing to the disk) here.

    BTW, have you got access to a disk repair program like Norton Disk Doctor (not that I'd recommend running it just yet unless you're desperate - might make things worse - I'd first try and pin down the problem).
     
  4. Dragon 185

    Dragon 185 Guest

    Hi Rettahc, unfortunately I don't have access to Partition Magic, can't really afford to purchase it either more's the pity.

    Hi Scotty _02, I ran fdisk and had a look. I changed the active drive to the number 2 unit, then I checked the partition info for it this was what I got:

    Partition=1, Status=A, Type=Non-DOS, mbytes=38170, Usage=100%

    TBH i don't like the look of that Non-Dos answer, I don't really know that much about this side of things, perhaps you could interperet it for me? Do you think I can retrieve the data from it? and transfer it to another drive?

    Thanx for the link to those utilities, I'll check em out, but won't run them till hopefully you reply to this post

    Dragon 185
     
  5. scotty_02

    scotty_02 Guest

    Hi Dragon

    Okay, according to both disk management and fdisk the partition exists and is active (which means bootable). Plus the size is about right for a 40Gb drive. But DM thinks its FAT32 and fdisk doesn't recognise it as any type of FAT. All this seems to confirm its a partition table problem and probably the rest of the data is intact.

    So where to go from here. Question to you: is the disk supposed to be FAT32 or NTFS? If its really FAT32 (which I'd be inclined to think) then it looks like when you reinstalled XP, setup was allergic to the active partition on your second drive and decided to change its type from FAT32 to something Non-DOS (to render the partition non-bootable). I don't know if this is in fact the behaviour of setup (maybe someone here does) because I always physically remove additional bootable drives before installation (having had problems with earlier OS's).

    If its just the partition type which has been changed, that's just one byte in the partition table entry that needs changing back :)
     
  6. dave holbon

    dave holbon Moderator

    Messages:
    1,014
    Location:
    London England
    My first consideration would be to check that your drive jumpers are correct for the cable connection. Second that XP and not ME has the boot sector MBR.

    I suspect that somehow the XP boot record has been overwritten by ME.

    To fix this will require that you boot from the XP CD, recovery consul and type Fixboot at the prompt.

    A typical Boot.ini file might look like this: -

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP
    Professional" /fastdetect
    C:\="Microsoft Windows Millennium Edition"


    Overview of the Start-up Process: -

    When you turn on your computer, it goes through an elaborate start-up process. The process begins when your computer performs its power-on self test (POST), which is followed by the POST for each adapter card that has a BIOS, such as SCSI adapters and video cards. The system BIOS then reads the master boot record (MBR)—the first sector on the first hard disk—and transfers control to the code in the MBR, which is created by Windows XP Setup. This is where Windows takes over the startup process. Here’s what happens next:
    1. The MBR reads the boot sector—the first sector of the active partition—which contains code that starts Ntldr, the bootstrap loader for Windows XP. The initial role of Ntldr is to switch the system to protected mode with paging enabled (to allow full memory addressing), start the file system, read the Boot.ini file, and display the boot menu.
    Note that Ntldr must be located in the root folder of the active partition, along with Ntdetect.com, Boot.ini, Bootsect.dos (if you’re going to dual boot), and Ntbootdd.sys (if you’re using certain SCSI adapters for the drive with the boot partition). For more information about sectors, partitions, and drives, see Chapter 26, "Managing Disks and Drives."
    2. If you select Windows XP from the boot menu, Ntldr runs Ntdetect.com to gather information about the currently installed hardware. Ntldr then uses the Advanced RISC Computing (ARC) path specified in Boot.ini to find the boot partition—the one where Windows XP is installed—and loads the two files that constitute the Windows XP core: Ntoskrnl.exe and Hal.dll. Both files must be located in the %SystemRoot%\System32 folder.
    3. Ntldr continues by reading the files that make up the registry, selecting a hardware profile and control set, and loading device drivers.
    4. At this point, Ntoskrnl.exe takes over and starts Winlogon.exe, which in turn starts Lsass.exe (Local Security Administration), the program that displays theWelcome screen (or the Windows logon dialog box) and allows you to log on with your user name and password.
    Understanding the boot process can help you to pinpoint problems that occur during startup. For more information, see "Using Advanced Startup Options."
     
  7. dave holbon

    dave holbon Moderator

    Messages:
    1,014
    Location:
    London England
    Courtesy of Microsoft:

    Let me know what happened.
     
  8. Dragon 185

    Dragon 185 Guest

    Hi,

    Scotty_02, yep it is indeed a FAT 32 partition, I don't suppose you know how to alter that 1 byte of the partition table entry to get access to the data on that unit? or is that what Dave Holden as explained in his thread, thanx Dave.

    I'll let you guys know how I get on, again many thanx for helping me with this problem.

    Dragon 185
     
  9. jawshoouh

    jawshoouh Guest

    ok, not sure if this'll help, but something similar happened to me after an XP recovery.

    i had 5 of my 9 partitions originally "locked out". there were more than 3 people who used my PC, and i only gave access to one of em (me). i assigned myself ownership and only gave my login rights to access those partitions in disk management (right click on my computer, choose manage). so when i did a recovery, since i forgot what the original workgroup name was, i assigned a new, different one, and in the process, blew away my rights to access my partitions that i had given myself access to. my only option seemed to be to repartition and/or format each of the partitions. since i didn't feel like losing close to 140GB of "stuff", and since i'm a dork, it took me a few days to realize that all i had to do was go BACK into the Manage console as an admin, and re-assign the security/ownership rights to my new login name.

    and, it happened again, but i know what happened this time. i just reformatted because i replaced my motherboard, and all the sudden, i couldn't even open any movie files on one of my partitions. i had to go back again and re-assign the ownership to my current, new login, before i could view anything.

    not really sure if that's the same problem you're having, but it kinda sounded like it...however, i dunno if it's the same, since my partitions were NTFS, and yours is FAT32.
     
  10. egghead

    egghead Double O Egghead

    Messages:
    504
    this is off topic but....

    i could see this happening if your xp installation on drive c: is fat32
    and your lost partition is ntfs
    drive c: fat32 will never see an ntfs partition

    double check to make sure your drive c: is ntfs and if its not this could be the problem

    convert c: to ntfs
    its a better file system

    you should goto www.ontrack.com
    get easyrecovery and scan your drive
    it should get your files back or tell you if its an ntfs drive

    please post your results



    hope this helps


    egghead
     
  11. scotty_02

    scotty_02 Guest

    You may find the Ranish Partition Manager useful. You can download it here . Among other things it lets you look at and modify the partition table.
     
  12. Dragon 185

    Dragon 185 Guest

    Hi,

    Egghead, thanx for the link to that easy recovery program, I downloaded the trial version and scanned the damaged drive, it found all the files I was after. Unfortunately the trial version of this program doesn't contain the facility to transfer those files to the other drive on my system, and I definately cannot afford the £345 they want for the full program.

    So near yet so far, I'll have to see if there is a freeware program of similar capabilities. So thanx again there is hope for my files yet.

    Scotty_02, yep Iv'e grabbed that little proggy, I'll use it once i've saved my files.

    Dragon 185
     
  13. Jahya

    Jahya Guest

    I'm being bad....

    This post *should* and probably will be removed but....

    irc.rizon.net
    #warezx

    check xdcc bots (bot 177 as of 12/5/02) for Partition Magic 8 (approx 450 meg) it has all the tools you need to recover the data and partition (at least in theory, luckily I have never had need to recover data from a lost partition, yet).

    There's another copy in #DeadPuppyWarez, but the bot is very unreliable.



    :p
     
  14. jawshoouh

    jawshoouh Guest

    Re: I'm being bad....

    yeah, that will probably get removed, but thanks for the info anyway ;)
     
  15. egghead

    egghead Double O Egghead

    Messages:
    504
  16. Dragon 185

    Dragon 185 Guest

    Hi everyone,

    I don't beleive it, it worked, the program that Egghead pointed me to, that would be Ontrack EasyRecovery Professional v 6.0
    allowed me to transfer my files from the the dodgy drive to my functional drive, yeehaa :D

    I'd all but given up hope of rescueing those files. Now all I got to do is re-partition and format my dodgy drive and transfer my files back to it.

    So my eternal gratitude to all of you, who replied with suggestions on how to rescue my almost doomed files ;)

    I really can't thank you all enough.

    Dragon 185
     
  17. scotty_02

    scotty_02 Guest

    Glad its sorted :)