XP/98 - Internet Connection Sharing

J

JOB

Guest
I have XP Pro on the pc wich is connected to the internet via ADSL. I have second ethernet card in the same pc wich is connected to a second pc running Win98. These two pc's communicate properly.

I ran Internett Connection Sharing Wizard on the first pc, who then made a diskett for the second pc. I then ran this on the second pc, and was told that everything was ok.

Still though I can't connect to the Internett from the second pc. Neither with Explorer, Outlook or just by "pinging" a host I can reach from the first pc.

The Ethernet card I use for connecting to the Internett (by PPPOEP) is "shared" and not "Firewalled, so everything should be ok there. But shouldn't the ICS Wizard had made a "bridge" between this and the second ethernet card?
Tried to do this manually, but are not allowed, cause the first card is used for ICS.
 
B

bmxjt

Guest
are you using a crossover cable to conect the two pcs?

did you say you can actually ping each of them from each pc or no? i wasnt clear.
 
J

JOB

Guest
Jepp, I use a twisted cable between the two pc's, and they have no problem connecting each other, reading each other files etc.

By pinging, I ment that while in "Command Prompt" I can ping other machines on the internet from the first pc, but not from the second. (Just mentioned that to show that I have absolutely no internett connection from the second pc.)
 
B

bmxjt

Guest
gotcha. it must be the TCP/IP settings in either the 2nd ethernet card in the 1st pc, OR the ethernet card in the win98 machine. Make sure your Win98 machine does NOT have internet sharing installed. Only the one pc connected directly to the internet can have this activated.

My roomate and I share an internet connection in a similar way. Her 2nd card TCP/IP is set with a basic IP of 192.168.0.1 and my system is set to auto obtain IP, use DHCP, no gateway. We went back and forth trying to get it to work correctly because we were having similar problems. Seems to be running perfect now.

hope this helps..
 
J

JOB

Guest
I don't have ICS on the second pc, and all the settings on the cards are excactly the same as yours...man, I hate computers sometimes! But I guess I just keep on trying, thanks anyway.
 
B

bmxjt

Guest
hmm.. well, the only thing I can say from experience is make sure your DHCP box is checked and DNS is disabled. Maybe someone else willcome along here shortly with some other ideas
 
R

relder

Guest
Both LAN cards should be set to obtain IP automatically. ICS doesn't like static addresses.

Can you PING the ICS computer from the second PC?

Try PINGing 192.168.0.1 first. That would be the LAN connection.
Then try PINGing the IP of the second NIC.

Let me know the results.

Future advice: DON'T use the Network Connection Wizard in XP OR the boot disks on other machines. Creates many problems. These connections can be setup manually much easier.
 
J

JOB

Guest
Got it!!!

When I ran ICS Wizard the first times, it recomended the dial-up connection for sharing, but when I tried this, all my connections went dead. So what I did was sharing the ethernet card instead. This was obviously wrong, because when I now changed it back, everything works perfect!

Not quite sure what I have done different than the ICS Wizard, but isn't that usually how it is with computers? (And I'm supposed to finish my Computer Engineer studies in two years...:)

Anyways, life is good, it's really late night back here in Norway, but I don't care. Now I can surf from my bed!

Than you for answering, guys.
 

Members online

Latest profile posts

Xie wrote on Electronic Punk's profile.
Impressed you have kept this alive this long EP! So many sites have come and gone. :(

Just did some crude math and I apparently joined almost 18yrs ago, how is that possible???
hello peeps... is been some time since i last came here.
Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.
Terrahertz wrote on Electronic Punk's profile.
Yo fellas!
Electronic Punk wrote on Sazar's profile.
Where are you buddy?

Forum statistics

Threads
62,005
Messages
673,461
Members
5,599
Latest member
Larry Chris