Wolfenstein

B

banter

Guest
I used to have voodoo 3 3000 then upgraded to geforce 2.

Return to Castle Wolfentsein worked fine on my old card but when i installed my new one, at the start it says:

Wolf 1.0.0 win-x86 Nov 13 2001
----- FS_Startup -----
Current search path:
C:\GAMES\RETURN~1\main\sp_pak2.pk3 (232 files)
C:\GAMES\RETURN~1\main\sp_pak1.pk3 (1342 files)
C:\GAMES\RETURN~1\main\pak0.pk3 (4775 files)
C:\GAMES\RETURN~1/main

----------------------
6349 files in pk3 files
execing default.cfg
couldn't exec language.cfg
execing wolfconfig.cfg
execing autoexec.cfg
Hunk_Clear: reset the hunk ok
...detecting CPU, found AMD w/ 3DNow!
Bypassing CD checks
----- Client Initialization -----
Cmd_AddCommand: map_restart already defined
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
Initializing OpenGL subsystem
...assuming 'gl/openglv5.dll' is a standalone driver
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\System32\gl/openglv5.dll.dll' ): failed
...shutting down QGL
...assuming '3dfxvgl' is a standalone driver
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\System32\3dfxvgl.dll' ): failed
...shutting down QGL
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\System32\opengl32.dll' ): succeeded
...setting mode 5: 960 720 FS
...using colorsbits of 16
...calling CDS: failed, bad mode
...trying next higher resolution: ok
...registered window class
...created window@0,0 (960x720)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (5)
...setting mode 5: 960 720 FS
...using colorsbits of 16
...calling CDS: failed, bad mode
...trying next higher resolution: ok
...created window@0,0 (960x720)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...shutting down QGL
...unloading OpenGL DLL
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
GLW_StartOpenGL() - could not load OpenGL subsystem

This means i can't play the game.

I reinstalled the game the same thing happened.

How can I make it work ?

Please Help !
 
R

robin.munro

Guest
Join the club!

I got that as well then it turned into a memory reference problem... No joy yet.

I had to set up win98 on a nother partition to play it!
 
S

snayar

Guest
Not a memory problem.

Same thing happened to me but with a Voodoo 5 5500, the exact same error. But then I downloaded the latest drivers and the Tools and that fixed the problem. FYI I downloaded the drivers from this site.

Regards,
Sergio Nayar
 
R

robin.munro

Guest
Luck you!

Tried virtually all the drivers available, used the same drivers on win98 with no problem.

So I am off for a fiddle.....

I may be back!
 
B

BloodLust DWS

Guest
hmmmmmm starge i just upgraded my card to the same g 2 my

wolfenstian runs GREAT could be a bad in stall on the drivers ? i had to install them 2 times for them to fully take ? got me why but running smooth know ....strange
 
R

robin.munro

Guest
Eventually...

Ended up scrubbing my hard drive, loads of wee problems plus I hate buying a pc with software that someone else has installed. Put on the latest detonator drivers and it runs perfectly now.

No memory or opengl problems.

My machine is....

Athlon XP 1800+
512MB
Geforce2 MX 400 64MB
SB Audigy

P.S. I don't trust Devilsown XP, nothing but trouble, may be paranoid but the MSDN volume licence seems be much more stable.
 
E

existenz

Guest
I know quite a lot of people with Devilsown's corporate XP, and they don't seem to be having any problems...:eek:
 
G

GeeZuZz

Guest
GLW_StartOpenGL() - could not load OpenGL subsystem
means that you don't have openGL installed on your computer, and wolfenstein only runs in openGL. Windows XP don't have OpenGL built in, so you need to download new drivers for your graphic card that contains OpenGL support.
 

LPDad

OSNN Addict
Joined
12 Jan 2002
Messages
205
I had that problem occur on 2 different machines...

one has a voodoo 3 3000 and the other has a TNT-2.

In both cases the problem was solved with non-XP installed drivers. (obtained from voodoofiles and nvidia)

Wolf runs great on both now.
 
A

AcID

Guest
Yes its the OpenGL wich XP doesnt have.

Had same problem when i 1st tryed XP and guessed about the nVidia Dets for XP..
 
G

GrassHopper

Guest
this may solve your problem!!

Open up your wolfconfig.cfg file and search for seta r_mode "X"
you can change your resolution by replacing the number witha lower value. i think three is equal to 640 X 480, 4 = 8 X 6 and so on...

i'm not exactly sure what the problem is but lowering you res lets you get back into the game. What size monitor do you have? if it isa 15" then you won't be able to run it higher than 1024 X 768.
Could be the problem? it looks fine in 1024 with 32bt colour anyways!

hope it works if not go to planetwolfenstein.com forums
 

XeoNoX

OSNN Senior Addict
Joined
3 Dec 2001
Messages
271
delete your multiplayer and single player config files or just reinstall wolf, wichever is easier for you
 

Members online

Latest profile posts

Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.
Terrahertz wrote on Electronic Punk's profile.
Yo fellas!
Electronic Punk wrote on Sazar's profile.
Where are you buddy?
Perris Calderon wrote on Electronic Punk's profile.
Hey EP! All good with me, applying for Microsoft MVP right now, should have done this a while ago.

Notifications don't work, I only found your response by coming back to hunt up some threads, if you want, give me your email address so we can keep in touch easier!
Perris Calderon wrote on Electronic Punk's profile.
EP, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there!

Forum statistics

Threads
61,997
Messages
673,410
Members
5,588
Latest member
dera