WMIC GetObject Permission Denied Err.Number = 70

fixitchris

OSNN Junior Addict
Joined
31 Oct 2006
Messages
12
What could be the possible causes of the permission denied error on this line?

Set objWMIService = GetObject("winmgmts:\\pc_name\root\CIMV2")

Thanks
Chris
 

fitz

Woah.. I'm still here?
Political Access
Joined
26 Apr 2004
Messages
4,085
hmm.. maybe not having permission to the computer you are trying to connect to?

Are you running the script under an account that has admin rights to the remote computer?
 

fitz

Woah.. I'm still here?
Political Access
Joined
26 Apr 2004
Messages
4,085
And are you sure the domain admins group has rights to access to the remote computer?

What OS is the remote computer running? What OS is the system you are running the script on? Are there firewalls involved? Client side or network side?

Are you trying to do double hop authentication?

What is the exact error message you are getting (ie: err.number and err.description)?

Is it just one computer? or all computers throwing this error back? Does it work connecting to the local computer?

Have you tried just connecting to the computer and not specifiing the namespace (ie: not \root\CIMV2)?)

Have you tried explicitly defining the authentication/impersonation level?
and/or explicitly defining username/password in your connection?

Have you tried just using IP address instead of computername?

Can you provide a little more info to try to help?
 

Members online

No members online now.

Latest profile posts

Xie wrote on Electronic Punk's profile.
Impressed you have kept this alive this long EP! So many sites have come and gone. :(

Just did some crude math and I apparently joined almost 18yrs ago, how is that possible???
hello peeps... is been some time since i last came here.
Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.
Terrahertz wrote on Electronic Punk's profile.
Yo fellas!
Electronic Punk wrote on Sazar's profile.
Where are you buddy?

Forum statistics

Threads
62,007
Messages
673,466
Members
5,598
Latest member
Larry Chris