• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Windows Update Error



Hi there,

I am having a strange problem with Windows Update. I use XP Pro Corporate edition and I have just wiped my PC to install on a new hard drive.

I installed as normal, connected to my domain and ran Windows update. I was asked to install update v4 and was presented with a list of updates after the scan. I checked the 12 critical updates and downloaded them. They all installed without a problem. I re-booted.

Logged back into my PC and ran update again to get the rest of the updates. Now, every time I run it I get a new page saying "Windows Update encountered an error." and an offer to select one of 3 links. 1). Windows Update Home Page, 2).Windows Update Support and 3).Report the error to Microsoft (error 0x3).

No matter what I do I can't get past this screen, even when I go to the corporate update page. It's not like I have not done this a thousand times with no problems at all.

Has anyone else found this problem and if so what did you do about it.

Thanks in advance,

Christian Briddon


Extinction Agenda
Political User
Hmmm my friend that should teach you that not every update applies to you. Critical updates yeah but, the other stuff is "if only this applies to you" patches." Im going out on a limb here but see if your Active x in explorer is functioning. Windows update needs this to function correctly.


Thanks for the reply but I don't think you understand properly. I have not installed any updates except the critical updates.

I can't get back to the update screen to even attempt to download the non-critical updates.

Also, this is a fresh install of XP on a clean HDD. The first thing I did was to run update. I have not changed anything at all so I can't see why changing any system settings will make any difference whem I have never done it in the past.




Extinction Agenda
Political User
I see what you mean by V4. I just went there and it also asked me to install it even though Ive been there quite a few times. I think Microsoft made another booboo. I think you also saved some headaches because I too am running XP pro corporate. Sorry it couldnt have been on better terms but Ill find out what I can.:cool:


update down

I too have xp corp and have the same problem currently, must be on micro's end.


I got some feedback from a friend at Microsoft, who has stated that there is an open case for this issue dating back to October 2001.

There currently isn't a resolution, except it does mention something about the problem being that the IUCTL.CAB file is an old version due to it getting stuck in a proxy cache, and the new update control calls it and gets an error as it is not the version it is expecting.

Try backing up the IUCTL.CAB file on your system and then deleting it, and try downloading the control again.

This does work (I had the same problem when I got home). IUCTL.CAB is in the "C:\Documents and Settings\<user>\Local Settings\Temporary Internet Files" folder (<user> is your relevant username). You may need to enable viewing hidden folders to find it. In here I had IUCTL.CAB and IUCTL.CAB?xxxxx files (x = numbers). I copied these to a spare folder, then deleted them. I ran Windows Update again and I got the message to restart the system for the changes to take effect. Once restarted - fixed!


Finally I've got it working!!!

Scritch, your mention of the proxy cache made me think about my firewall.

I turned the web proxy off and tried update again and it worked!!

I think there must have been something crappy in there and turning it off sorted it.

Thanks to you all for your help and suggestions.



Same problem but no IUCTL.CAB

I have the same problem at Windows Update as you had but I do not have the file IUCTL.CAB. I searced the whole computer for this file but nopes.. only one file called something like IUCTL and it was "iuctl.dll" in C:\windows\system32.

Anyone have a clue to my problem?

My Active-X is activated so that is not the problem here.



If you have some of the ActiveX badly installed, read this for the way to fix it. http://corporate.windowsupdate.microsoft.com/en/help.htm#Corruptsitecontrols

It pertains to Windows 2000, and does not necessarily have all of the items in XP, but I know it works for sure.

Also make sure you don't run any web-proxy, like The Proxomitron or ZoneAlarm's ad-blocking proxy, etc. Oterwise say bye bye to windowsupdate

If you need to dl the files to install them manually later, use this link
http://v4.windowsupdate.microsoft.com/en/default.asp?corporate=true ; although you will still need the activeX applet working for it.

Members online

No members online now.

Latest posts

Latest profile posts

Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
What a long strange trip it's been. =)

Forum statistics

Latest member