• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Windows Update does not work

L

Luna64

Guest
#1
Just replaced my faulty Linksys router with an a D-Link 704P .

Internet and download are now twice as fast and stable, but I got two problems.

The first one is that Windows upadate will not find any updates for my PC. It did before, but now right after I reinstalled XP and SP1, it brings up nothing. I know my system is not up to date so whats up ?

Secondly is if anyone here knows how to use port forwarding with a D-Link please tell me. With the linksys it was pretty easy but I cant figure the D-Link out.

I will not go back to the Linksys as it was a very poor router. Slow and very bug prone, but atleast Windows Update worked with it :-/
 
#2
SP1 will mess up Windows Update if it thinks the code is non-legit. That's all I know.

The D-Link shouldn't be a problem. Found this on the D-Link homepage:
1. Go to http://192.168.0.1
2. Type in "admin".
3. Under one of the menus (don't know which) there is Virtual Server.
4. Forward the ports you want.
5. Done. :)
 
L

Luna64

Guest
#3
This is really strange.

I did another format and clean install of XP, except this time I used a different serial and I have the same problem.

Windows Upadate worked fine with the serial that it came with it in the past. I don't see why they would suddenly mess me up. I have used SP1 in the past also and it installed and let me update with no problems.

I really do think it is my D-Link router, but I have no real way to tell.

Another thing I noticed is that if I try to log into www.livejournal.com at my home, I am logged off right after clicking any link on the page. Yet if I log in at work, I keep my log in untill the browser closes.
 
#4
I have the same router as you do ... and Windows Update works fine.

I don't know what the problem is, but if you need help with anything else on your router, ask, and I can help you out.
 
L

Luna64

Guest
#5
Well I could use your help now.

I have three different routers.

First was the Linksys, then I have the D-Link DI-704 and the DI-704P.

I took off the Linksys and hooked up the 704P and it works fine except for that it wont let me log into my livejournal , and that windows update does not work.

The 704 I cant get to work at all. Usually there are two orange lights on the router, and the top one blinks, the bottem one stays constant. But on the 704 I cant get the router to find my IP and such.

What I really want to know is do you have any tips for installing a router (D-Link 704)?. I plug in the Power, LAN, and my PC into the router. My PC is off at the time. I then turn on my PC, and it boots up to XP. From there I do a /release and /renew in command prompt and my 704P usually works fine right off the bat , or after a restart.

The problem is I can't get the 704 or my Linksys to work with this method. Strange because just a few days ago my linksys worked fine :( The 704 just sits there and tries to find the IP. I can log in at 192.168.0.1 on both D-Links but only the 704P works.

I am really really confused and distressed over this.
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,962
Messages
673,240
Members
89,016
Latest member
timpage