• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Windows Defender Updating Problems

kcnychief

█▄█ ▀█▄ █
Political User
#1
I have had two laptops in the past week that are having issues updating Windows Defender. Both laptops didn't have Defender installed before I touched them.

The first had small amounts of virii/spyware present, but was successfully cleaned and eventually was able to update. Basically I just kept trying, and trying, and trying. Not sure what triggered it or changed, but eventually this one got the updates.

Laptop number two was a fresh install of the OS, still not able to update. There isn't really a specific error however, it simply states that Windows Defender cannot find any new signatures or something like that.

Anyone else having problems lately, or any suggestions I can try? As it stands I need to update laptop #2 still, but would like to know how to avoid this headache in the future.
 

tdinc

█▄█ ▀█▄ █
Political User
#2
I have had the same problem with the auto updates as of late..after doing some investigating. this works wonders...


1. Shut down Windows Defender

2. Remove the current signature file. To do this, click Start, click Run,
type: Msiexec /x {A5CC2A09-E9D3-49EC-923D-03874BBD4C2C}
and then click OK.

3. Open Windows Defender.

4. Check for new definitions. To do this, click the Help options arrow next
to the Windows Defender Help icon, click About Windows Defender, and then
click Check for Updates.


you should now have the latest definition updates...:)
 

kcnychief

█▄█ ▀█▄ █
Political User
#3
Sweet man, I'll try that out when I get home and let you know.

Is that a bug that is going around lately, perhaps something that can be reported and fixed? Or something temporary on their side?
 

tdinc

█▄█ ▀█▄ █
Political User
#4
I believe this issue has been around for a few weeks or more, I would think it has been reported, im sure its being worked on...
 

madmatt

Bow Down to the King
Political User
#5
Actually, to make it easier...

Go to C:\Program Files\Windows Defender
Right click AS_Sigs.MSI
Uninstall
Open Windows Defender
Help
About
Check for Updates

It does the same thing but a bit easier. The bug has existed since beta 2 was released.
 

kcnychief

█▄█ ▀█▄ █
Political User
#6
Thanks for the info madmatt...

I have been using Defender for about a month or more on selective machines, haven't had this problem. Does it only effect new installs?
 

madmatt

Bow Down to the King
Political User
#7
I'm not quite sure why it happens to be honest. I've experienced this problem several times in the test group I have setup.

I'm sure it will be resolved with the next release. I've read about several others having the same issue on the WOC forums.
 

kcnychief

█▄█ ▀█▄ █
Political User
#8
This worked like a champ guys, thanks a bunch.

Reps ++ all around :)

EDIT: Except for you mm, I have to spread some love first.
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,962
Messages
673,240
Members
89,015
Latest member
loxioalix