Win XP Pro - CD-Rom not working...

P

playndirty101

Guest
Please help!

Just installed win xp and my cd-rom doesnt work at all, did i do something wrong?

Whenever i pop in a cd its like my pc doesnt recognize the cd-rom...not working at all!

Any fixes? please help!!

Thanks
 
S

stuy_b

Guest
:) Hi.

Have you tried going into hardware devices, and looking to see if XP is reporting any errors.

Also check for any errors reported in the logfile (Adminsitrator tools).

You could try removing the CD-ROM entry from the device manager list , rebooting and see if XP re-installs the drive correctly.. IT SHOULD!.

Check your motherboard manufacturers website for any BIOS updates.. I found I needed one on my MB.

Hope this helps.

cheers

Stuy_b
 
P

playndirty101

Guest
yeah i checked that and everything checked out fine.. i even tried that and xp detects it but not working...

hmm? would it be aspi layer?
 

JJB6486

Retired Mod
Political Access
Joined
3 Dec 2001
Messages
1,207
Probably not. ASPI layer is only needed for burners not detected by recording softwatre. Check your BIOS settings, make sure that the modes are set correctly (UltraDMA or PIO) and other BIOS settings related to that.

JJB6486
 
P

playndirty101

Guest
hmm how do i check bios? sorry im not good at this...

can you give me a step by step? Thanks!!
 

Lonman

Bleh!
Joined
2 Dec 2001
Messages
2,642
I had this problem myself. Try leaving a CD in the drive(s) when you boot up and see if XP will pick it up then. If it does then all you may need to do is update your 4in1 drivers and/or possibly install the mini-port drivers - assuming you have the VIA chipset.
 
P

playndirty101

Guest
tried that.... had the cd in the cd-rom...nothing...

argh!! thanks though... what else can i do?

shall i uninstall cd-rom... (i may need help with this) and disconnect...

then reconnect and boot up xp let it find the drive?
 

Lonman

Bleh!
Joined
2 Dec 2001
Messages
2,642
Do you have the VIA chipset? If you have the VIA chipset, do you have the latest 4in1's?

Have you installed any burning software? If you have EZCD or an older version of Nero Burning Rom installed, they've been known to mess up CDrom drives.

Is your bios up-to-date? Are there any firmware updates available for you CDrom drive?
 
P

playndirty101

Guest
i've installed EZCD 5 platinum.. i think this is what messed it up..

how do i update bios? if you can give me a step by step?

not sure about the firmware updates...
 

Lonman

Bleh!
Joined
2 Dec 2001
Messages
2,642
Originally posted by playndirty101
i've installed EZCD 5 platinum.. i think this is what messed it up..

how do i update bios? if you can give me a step by step?

not sure about the firmware updates...
It was working ok before this? I think you found your culprit... do a search, upper right, on ezcd and see what comes up.

If you have System Restore active, restore back to before you installed that Roxio junk and find alternative burning software.
 

Ci2e

XPert
Joined
28 Nov 2004
Messages
277
Like said before if you were to look on the Roxio site there are 2 updates called:

  1. Xp_up.exe
  2. ECDC_v5.02d_up.exe
    [/list=1]

    You should run these in order and restart after you install Roxio and each file update above; so you should restart a total of 4 times.

    Since its too late to do that your best off just doing a fresh install of XP; don't install windows over itself b/c that just doesn't fix everything. I have restarted many times. I am finally happy that I have no blue screens and all my problems are solved; just about :p
 
P

playndirty101

Guest
yeah tried that.... updated everything...

cd-rom still not working...

i uninstalled in device manager and re-installed...not working..

now, it reads (sorta) then pops up a message "insert disk to drive E:"

hmm?
 
R

robin.munro

Guest
I'm joining the nightmare!

I have done nothing other than turn og the IMAPI driver.

Windows now says it doesnt have a driver for my drive! (it's had one for the past 3 month!!)

I have a TEAC W516EB by the way...

I have turned the IMAPI back on, and although it has found the drive (i installed the standard cd-rom drivers) the drive hangs the system when it tries to read the disk. I unhangs the second I release the disk.

Oh yeah, and the system hangs on boot-up 50% of the time, just after the logo comes up...

My DVD-ROM drive is fine.

I have the most up-to-date motherboard bios and CD-ROM firmware... PLUS because my drive was aparently 'Designed' for XP TEAC do not issue drivers for them!:mad:
 

Lonman

Bleh!
Joined
2 Dec 2001
Messages
2,642
Try swapping connections around. I saw one guy fix his problem by setting the drive up on another IDE channel... experiment with it as master and slave in different configurations.

Also make sure you have your most up-to-date chipset IDE drivers... experiment with those too if the newest don't work... roll them back one or two revisions - that sort of thing.
 

Members online

No members online now.

Latest profile posts

Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.
Terrahertz wrote on Electronic Punk's profile.
Yo fellas!
Electronic Punk wrote on Sazar's profile.
Where are you buddy?
Perris Calderon wrote on Electronic Punk's profile.
Hey EP! All good with me, applying for Microsoft MVP right now, should have done this a while ago.

Notifications don't work, I only found your response by coming back to hunt up some threads, if you want, give me your email address so we can keep in touch easier!
Perris Calderon wrote on Electronic Punk's profile.
EP, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there!

Forum statistics

Threads
61,997
Messages
673,411
Members
5,589
Latest member
EmilyFox