Web server initial response slow?

Electronic Punk

willalwaysbewithyou
Staff member
Political Access
Joined
2 Dec 2001
Messages
18,694
I have a few web servers on my work lan that when you attept to reach them via http initially they are very very slow to respond, but after that initial pause of around 7seconds its generally quite quick we have other sites on the same network that are instant.

All seem to use asp varying between .net framework 1.1 and 2 and I am not sure what I can optimise to speed things up.

Anyone have any ideas?
 

Electronic Punk

willalwaysbewithyou
Staff member
Political Access
Joined
2 Dec 2001
Messages
18,694
Actually takes 29 seconds for the first load then instant after that.
 

Electronic Punk

willalwaysbewithyou
Staff member
Political Access
Joined
2 Dec 2001
Messages
18,694
Reading quotes that "This sounds normal, although a bit slow. The first time the Web service is
called, ASP.NET has to compile it and get it into memory. After that, it
should run fast as you say."

There is no reason it should have dropped out of memory however!
 

X-Istence

*
Political Access
Joined
5 Dec 2001
Messages
6,498
My school recently got an patch from Microsoft and updated their backend SQL servers, and their "intranet" is not so slow it seems like I am back on dialup. I called them out on it, and said it was pathetic, but alas they can't do anything until they rewrite the entire thing in .net 2.0 or whatever.
 

Electronic Punk

willalwaysbewithyou
Staff member
Political Access
Joined
2 Dec 2001
Messages
18,694
Did some more checking, basically the workers are recycled at 1:40 every morning so that explains why its slow as I am the only one using the website at the moment to test it - I have changed that back to just recycling the workers every 24 hours if they are not used.

Fixed community server, but as far as the other website goes, its just crap and I think it needs removing and reinstalling from scratch somewhere else!
 

Sazar

Rest In Peace
Joined
12 Apr 2002
Messages
14,905
I have noticed this a little, but figured it was probably just and occasional slow-down depending on traffic.
 

X-Istence

*
Political Access
Joined
5 Dec 2001
Messages
6,498
I have noticed this a little, but figured it was probably just and occasional slow-down depending on traffic.

Not this server. This is at his work! We don't run MS Windows.
 

Sazar

Rest In Peace
Joined
12 Apr 2002
Messages
14,905
I wasn't talking about this server dude :)

Was talking bout mine at work and a couple of places I have been hooked up to.

:cool:
 

Members online

No members online now.

Latest profile posts

Also Hi EP and people. I found this place again while looking through a oooollllllldddd backup. I have filled over 10TB and was looking at my collection of antiques. Any bids on the 500Mhz Win 95 fix?
Any of the SP crew still out there?
Xie wrote on Electronic Punk's profile.
Impressed you have kept this alive this long EP! So many sites have come and gone. :(

Just did some crude math and I apparently joined almost 18yrs ago, how is that possible???
hello peeps... is been some time since i last came here.
Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.

Forum statistics

Threads
62,013
Messages
673,480
Members
5,607
Latest member
Akinerb