User Name grayed out on C$ shares

K

kingnothing

Guest
I have my desktop and notebook hooked up to a hub, and I'm trying to access my notebook's drive using the \\NOTEBOOK\C$ method.

I get prompted for my User and password, but they user part is blanked out and displays \\NOTEBOOK\USER NAME instead of allowing me to define which user name I want to use. I also input the password for that user name and it won't accept it even though I've checked the password is correct n times. I'm running NTFS.

Any help would be appreciated.
 

JJB6486

Retired Mod
Political User
Joined
Dec 3, 2001
Messages
1,207
Anything with a $ after the name is an administrative share. They are NOT publicly accessable from remote comptuers, and used by the local OS. You must enable file sharing if using simple, or if using advanced click the "Create New Share" button user the sharing tab, then click the "Permissions" button to set up user access.

JJB6486
 
C

chooch

Guest
Actually hidden shares ($) are accessible remotely, that is one of their purpose. First you will need an account on the remote computer with administrator rights, you will need to uncheck Simple File Sharing from Tools Menu/Folder Option/View Tab, drop to a dos prompt and type the following:

net use "Drive letter (i.e. z: )" \\"computername or IP address"\c$
By default it seems that it wants to use the guest account but it will give you an option to enter a different username and password (it needs to be an administrator of the remote computer).

You could also Map a Network Drive from Windows Explorer, select the drive letter you wish to use, enter the share name, in this case it would be \\"computername or IP address"\c$, click on Connect using a different username and enter the username and password you wish to use (it needs to be an administrator of the remote computer).

You could also disable hidden shares by adding the following in to the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters

dword=AutoShareServer
data=0

and

dword=AutoShareWks
data=0

I've attached the reg file as well. You must also uncheck Simple File Sharing from Tools Menu/Folder Option/View Tab, right click on your c:\ drive, goto Sharing and select do not share this folder, there also additional hidden shares on your system for every HD you have and for the windows or winnt directory, that could also be removed (the $ share), hope this helps.
 

Members online

No members online now.

Latest profile posts

Electronic Punk wrote on Sazar's profile.
Where are you buddy? :(
Perris Calderon wrote on Electronic Punk's profile.
Hey ep!

All good with me, applying for microsoft mvp right now, should have done this a while ago.

Notifications don't work, I only found your response by comming back to hunt up some threads, if you want, give me your email address so we can keep in touch easier, mine is perriscalderon at gmail
Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?

Forum statistics

Threads
61,978
Messages
673,285
Members
89,064
Latest member
Plesuvius