USB2 not detected after booting.

pluto

OSNN Addict
Joined
Jan 31, 2004
Messages
202
#1
Hey,

Im having trouble with Windows not detecting my new USB2.0 PCI card after rebooting.

What happens is that I install all the software that came with the card then plug in my Zen Xtra and transfer files at USB2 speed. Then after restarting, the USB2 card operates at USB1 speed and Windows informs me that the Zen Xtra is a high speed device operating on a low speed port. I reinstall everything again and it works at USB2 speed. Same thing happens after rebooting.

I have reinstalled SP1 and tried the drivers from Qtecs website, but they dont work at all, the executable is corrupted.

I previously had USB1 ports but I uninstalled them to install the USB2 card. Device Manager insists that its USB1.

Is there anyway of fixing this?
 

LeeJend

OSNN Veteran Addict
Joined
Jan 25, 2003
Messages
5,291
#2
You have to have Windows SP1 installed or you don't get USB 2. The drivers are in a windows update. SUPRISE!
 

pluto

OSNN Addict
Joined
Jan 31, 2004
Messages
202
#3
Umm I said I reinstalled SP1. I also said I did manage to get USB2.0 to work. Did you not read my entire post?
 

falconguard

Carbon based lifeform
Political User
Joined
Feb 11, 2004
Messages
3,406
#4
Try moving the USB 2.0 to a different PCI slot, you might me on a shared irq
 

LeeJend

OSNN Veteran Addict
Joined
Jan 25, 2003
Messages
5,291
#5
Obviously not. I missed a few lines.

It sounds like windows is rolling back the updated drivers with it's own at reboot. It annoyingly does stuff like that when it thinks it is in your best interest.

My first hunch here is that you should turn the MB USB back on. No rational reason. Just a hunch.

Possibilities
1). Could be a MB compatibility issue (bios or driver so check the FAQ on the MB web site and check the FAQ on the USB makers web site). Unlikely, it sounds more like Windows meddling with your setup.

2). Some devices will not install properly if you do things out of sequence. Follow the instructions precisely. I have some that require the software be installed BEFORE the device is physically installed. If you don't it doesn't install properly. This would be especially true for an add on card that has functions not supported by the MB and Bios. Uninstall drivers and hardware before attempting a new install.

3). Go to device manager and open the USB device properties. There should be USB host controller (USB 1.1) AND a USB enhanced host controller (USB 2.0) items. Not sure what it will show since you turned off your USB 1.1.

There should be no yellow exclamation marks and when you open properties it should say working properly, or list problems. My drivers say Microsoft. With an add in card I'm not sure what yours will say. If they say Mircosft you could try changing them to the card drivers manually. If there is a PCI IRQ conflict it will say that also.

4). Another long shot. Some cards are finicky and want to be in the first PCI slot. The manufacturer FAQ or manual should mention this.
 

pluto

OSNN Addict
Joined
Jan 31, 2004
Messages
202
#6
I have tried what I could and the USB ports are no longer working. hmm, not even the mainboard updates work and there are no patches on the Microsoft website.

Has anyone done a clean install of WinXP with USB 2.0 ports and got them to work?
 

Tweakfiend

OSNN Senior Addict
Joined
Jan 6, 2004
Messages
340
#7
I have found that occasionally the USB2 option needs a "kick start"
Try going to Mevice Manager and if the "enhanced USb Controller" is not showing choose to update the driver to force it to update itself from SP1 to support this function.
 

pluto

OSNN Addict
Joined
Jan 31, 2004
Messages
202
#9
I have just done a clean install of WinXP, with SP1 and the USB 2.0 patch from Windows Update, plus the USB 2.0 driver from VIA. The USB 2.0 ports still dont work.

Any ideas on how to fix this?

EDIT

I tried installing the USB 2.0 patch again and the USB 2.0 ports work fine now.
 

Members online

No members online now.

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Hey ep!

All good with me, applying for microsoft mvp right now, should have done this a while ago.

Notifications don't work, I only found your response by comming back to hunt up some threads, if you want, give me your email address so we can keep in touch easier, mine is perriscalderon at gmail
Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...

Forum statistics

Threads
62,030
Messages
673,544
Members
89,038
Latest member
Samhicks