USB Mouse Issues, HELP!



Ok, here's the deal. I have Winxp running on my computer, everything's been peachy except for my damn mouse. I have a Microsoft USB intellimouse Explorer.

Every now and then (about 3-5x a day) my mouse just freezes on the screen. Everything else is fine, the onscreen pointer just won't move. The light under the mouse goes out as well when this occurs.

Since it's a usb mouse, I calmly reach behind my computer, unplug it, and then replug it back in. Then it works fine again.

What's the deal? Is it my video card drivers? I'm running the beta detonators....

Is it my usb hub? I have a DLink Powered usb hub. It has it's own power supply, and it has seemed fine to me other than my mouse troubles.

Help me! This is REALLY ANNOYING!!!



OSNN Veteran Addict
6 Dec 2001
I find that USB Mice and Keyboards have a few problems such as the ones you describe, there is no advantage to using a USB mouse or keyboard, they seem to be a waste, but thats my personal opinion

I believe your mouse came with a USB to PS2 Adapter. I recommend using the adapter and am betting you will have no more problems, if your mouse didn't come with the adapter head to a comp store, they usually only cost a few bucks

This isn't really a fix, but it helps to avoid the problem from ever happening, it's kinda on the same line with people who have a nic in their computer and plug their cable modems into the usb ports and proceed to have problems...yet if ya plug it into the nic your fine :)


If you play online games, like Counterstrike or other First Person Shooters, the USB mouse has advantages over the PS2 connection in that it has a much faster refresh rate and sensitivity resulting in faster frags aiming etc.
I had weird mouse behavior episodes when connected to my PS2 port. Switching to USB has eliminated them; however if you use a bunch of USB items (particularly printer & scanners) they can make your mouse freeze up when they run on the same USB controller. Try pluging the mouse into one of the computer ports instead of the D-Link hub and see if problems go away..


I have 2 suggestions...

1) are you overclocking? If so, try reducing the overclock somewhat. The USB controller (built into the Southbridge IC) is quite often not as good at being overclocked as other components.
This is sad if it is the cause, but using the PS2 adapter may allow you to keep going at that clock speed.

2) I and quite a few friends have had the wire break on our Intellimouse explorer. Where the wire enters the mouse, Microsoft no longer use a rubber grommet. This means there is a sharp kink on the cable when the wire is pulled.
This led to it disconnecting periodically and no longer allowing the mouse to work unless rebooted.

However if you ARENT using a USB keyboard......
I did find that if u can get to Control Panel/System Applet/Device Manager (with the keyboard) and completely remove the USB controller from the system. Then do Scan for New Hardware on the Action Menu.
My mouse sprang back to life as long as the cable wasnt still in a bad position.

A dodgy cable can be fixed but make sure you are OK at pulling gadgets apart.


Pretty much the same problem here. About once every hour or so I will here a little "ding" sound and all USB devices cease to work or have powe. About 3-5 seconds later I get a slightly different "ding" and they come back on.....wierd.


also, have you tried a pci usb controller card? they're only about £15-£20 in the UK, so they're more than likely to be cheaper in the US. A lad on IRC i know had problems with his USB ADSL modem losing connectivity and when he got a pci card (cheaper alternative to a hub) he found the problems were solved.

also, take a look in device manager (right click my computer > properties > hardware > device manager). Go to the USB bits at the bottom of it. I cant remember if its the actual USB controller or the Root hub that has it in, but one of them has an option to "Turn off power to this device when no longer needed". It will more than likely be ticked (I've seen this on my own system when I was bored and started moochin around to see what I could learn lol).

good luck :)


I just looked on the computer and the power setting for USB is actually on the USB Root Hub bit on Device manager.

Go to the properties of "USB Root Hub" and go to the "Power" tab at the top and untick the box which mentions turning off this device to save power. You might have to reboot.


Ok, I unchecked it, i'll let you know if this works!!



Members online

No members online now.

Latest profile posts

Xie wrote on Electronic Punk's profile.
Impressed you have kept this alive this long EP! So many sites have come and gone. :(

Just did some crude math and I apparently joined almost 18yrs ago, how is that possible???
hello peeps... is been some time since i last came here.
Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.
Terrahertz wrote on Electronic Punk's profile.
Yo fellas!
Electronic Punk wrote on Sazar's profile.
Where are you buddy?

Forum statistics

Latest member
Larry Chris