USB Keyboard issue

zapoqx

Striking Master
Joined
Jun 1, 2005
Messages
460
So I have a G15 Keyboard and the keyboard works great when its the only USB connection used on the computer. But when I connect ANY OTHER USB CONNECTION TO THE COMPUTER (As in it doesn't matter the device for any USB connection), the Computer will not detect that USB Keyboard. In result, I have 2 Keyboards connected at all times as of right now:
A G15 Keyboard (Used all times)
A Regular PS/2 Keyboard (For load up and going into CMOS).

Anyone ever run into this issue before?

Thanks
 

kcnychief

█▄█ ▀█▄ █
Political User
Joined
Apr 8, 2005
Messages
16,948
Rather odd IMO.

What is the OS you are running? Have you tried the G15 in other USB ports besides the one it is installed in? Have you tried removing and then re-installing your USB channels? Have you tried the G15 in another machine if applicable? Do you have the software installed for the G15?
 

zapoqx

Striking Master
Joined
Jun 1, 2005
Messages
460
Hmm... I don't think I was clear enough (maybe cause I was half-tired when I wrote it)...
Let me better explain... this is only when bootup happenes. Like not yet in Windows. You know the screen you can get that says to press delete to go into the cmos and then if you dual boot your system, a menu to choose what OS you want to go into. Just those parts it don't work on USB if it isn't the ONLY USB device. If it is the only USB device, it works perfect. On my old system, it worked just fine so I'm thinking its something to do with the motherboard itself maybe mistakening things like the Phone Connection or the Printer connection as part of the keyboard or not wanting to draw the power to the keyboard innitially and I say that as another possibility because the keyboard blinks when powering up the system, like all keyboards would give a signal if its activated, but then it doesn't let the light work and you can't do anything until Windows starts putting drivers to itself and as it gets close to coming into Windows, the Keyboard turns on. That is why I'm forced to use the PS/2 Keyboard for only that and I find it annoying to use 2 keyboards in the first place just for seperate things.
 

kcnychief

█▄█ ▀█▄ █
Political User
Joined
Apr 8, 2005
Messages
16,948
Thanks for clarification :)

Has it always occured this way, or did something change that caused it? I would check to see if there is a BIOS upgrade for your mobo, then check for USB legacy support in the BIOS, almost sounds like it is having problems detecting USB as a whole, except when it is the only device.
 

zapoqx

Striking Master
Joined
Jun 1, 2005
Messages
460
Well actually, funny you should mention about a bios upgrade for my mobo. It acted this way before I put a flash upgrade back when I was going to OC my CPU. Once I did the upgrade, it still didn't resolve the issue.

As for the USB Legacy Support, I don't recall if there was an option saying that specifically... but I'll check it when I return home as I'm about to leave for school.
 

Sazar

F@H - Is it in you?
Staff member
Political User
Joined
Apr 12, 2002
Messages
14,905
I wonder if the mobo is acting as a usb hub and doesn't have enough juice.

I also wonder if you kinda have to have a usb 2.0 connection to handle the g-15 best.
 

zapoqx

Striking Master
Joined
Jun 1, 2005
Messages
460
lol check my profile. Its an ECS KA3MVP mobo which means all 8 usb ports (6 in back, 2 up front) are 2.0
 

Members online

No members online now.

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Hey ep!

All good with me, applying for microsoft mvp right now, should have done this a while ago.

Notifications don't work, I only found your response by comming back to hunt up some threads, if you want, give me your email address so we can keep in touch easier, mine is perriscalderon at gmail
Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...

Forum statistics

Threads
61,974
Messages
673,294
Members
89,042
Latest member
Pancake