Undeletable folder?!



Here is the scenario....

I downloaded a file with getright and it put it in a folder named after the source IP address... (NTFS system by the way)

Now I can add/delete files and folders within this folder, but I can't delete the actualy folder itself.

1. I have scaned the HDD for errors and come up with nothing...
2. Using the command prompt, I can see the folder however when I try and delete it, it says 'cannot read from source file or disk (as in xp)
3. When I click on properties, everything is blank and all the boxes (read only etc) are unticked)

Now here is the strange thing...

If I add a file to the folder, it create an identical folder of the same path!

This probelm has been here for months now, with no other incidents...

Anyone takers??!! :D


what is the error you get? does it say it is being used by another program or another user? if so.. you have to close the program that is using it... and then you will be able to delete the folder.... and then go into options of (getright) and use another folder... dont have it make another one...



No, in XP and the command prompt I get the same error....

'cannot read from source file or disk'

Even when I reboot and stripe the system processes to a bare minimum, i still get this error. :confused:

Hey here is another twist in the tale! - I can send it to the recycle bin, but not remove it from there!!! - same error!!!


Are you able to rename the folder? Sometimes changing the name will get rid of any of its associations to something that might be preventing it from deleting. Worth a shot anyway.



Can't rename it... don't think it is linked to a program or the duplicate folder anomaly would not occur....


NTFS Stoner
is it small enough to move onto a floppy? I managed that with a wierd file from kazaa. shift delete failed etc.. same as you. then i moved it to A drive and binned the floppy :)


Had exactly the same problem with a tweakxp folder, would not delete from the command prompt or safe mode either. Someone here suggested one of the disk wipe programs, that also did not work. Finally got rid of it with a format and reinstall.



Maybe dumb to even mention this, but is the folder set as "Read-Only" or "System" ??



As I said, it has no attributes, all properties are blank, with none of the boxes ticked.

When I send it to the recycle bin it goes there, but try and empty the bin it says 'cannot remove folder XXXXX, cannot find specified file'

Can't restore it either, may try Norton to try and completely clean it doing the 1's and 0's thing....


Hmmm... 'Cannot read from source file or disk'

Since everything else you've tried doesn't seem to work, I have a suggestion. Perhaps you need proper ownership to delete the file or get around some kind of wierd XP security stuff. I read that you've tried getting rid of the folder in Safe Mode without success. But have you tried getting rid of it in Safe Mode as administrator with proper file/folder ownership? I remember, even logged in as Administrator I could not really view the files in my protected user account.

Try this:
Try deleting the file/folder as Administrator in Safe Mode. If that doesn't work use these steps to change the ownership and then deleting the file. You change ownership as follows:

LOGGED IN WITH THE ADMINISTRATOR ACCOUNT, not just your normal user account with administrative rights:

(1) open Folder Options from the Control Panel
(2) choose the "View" tab and scroll to the bottom of the options
(3) un-check (deselect) the option "Use simple file sharing"
(4) choose OK
(5) open Windows Explorer and right click the folder to delete
(6) choose "Sharing and Security..." and choose the "Security" tab
(7) at the bottom of the box choose "Advanced..."
(8) choose the "Owner" tab
(9) in the "Change owner to" box, choose "Administrator" or "Administrators" and check (enable) the "Replace owner on subcontainers and objects" option.
(10) choose OK and OK again
(11) you now "own" the folder, so try deleting it again and then permanently from the recycle bin.

I suggested using the Administrator account because it is the most powerful.

Lemme know how things turn out or if that did nothing for you.


Died at stage 6!

The folder has no security or sharing tab when empty, only when it has content (unlike all other empty folders) - I remember adding files and getting the tabs back, however whenever I tried to delete the folder the files inside deleted and the sharing and security tabs left with them...

As it is in the Recycle bin now and it wont let me restore it, I can't put anything in it, to get the security tab!!

I think it must be a corrupt bit in the filling structure for the folder...

Thanks for helping though, I think it is a dead cause!


this crap is pretty well known by me in xp, the only way i have found to get rid of these files (the ones that give me the "file in use" errors) is to reboot into safe mode command prompt and just del "filename.ext"

im sure this will be addressed in sp1


Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
What a long strange trip it's been. =)

Forum statistics

Latest member