• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Unable to access folder on PC in my network?

B

Bablos

Guest
#1
Hi There...

I'm trying to access the 'Program Files' folder on the D drive of my second PC, but I keep getting the following message;

"\\<PC Name>\d\Program Files is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions."

My second PC can quite happily access all shared folders on this PC, and I can quite happily access all of the files on the second PC from this PC, so long as I don't go near the 'Program Files' folder on the D drive!

What's going on? If I have access permissions for the rest of the drive, why not the Program Files folder?

Hope someone can help.


Bablos.
 
#2
Some folders, including Program Files, are not set to be shared by default (security and all). You'll have to set the permissions manually. No biggie. I believe Windows and Documents and Settings are blocked as well.
 
B

Bablos

Guest
#3
How do I go about altering the permissions manually then?

I'm able to access anything in 'Documents and Settings' on the same drive, and from the other PC, I can freely access the 'Program Files' folder on this machine. Odd that it's just restricted to the one folder, on one machine.

Hope someone can help.


Bablos.
 

oDin

xp m0nk3y
#4
Originally posted by Bablos
How do I go about altering the permissions manually then?

I'm able to access anything in 'Documents and Settings' on the same drive, and from the other PC, I can freely access the 'Program Files' folder on this machine. Odd that it's just restricted to the one folder, on one machine.

Hope someone can help.


Bablos.
just right click the folder you want to share. select properties and choose the sharing tab. then simply share it. don't need to play with the sharing permissions.

oDin.
 
B

Bablos

Guest
#5
Hi There...

I've already set up sharing for the entire drive, so I shouldn't have to set it up for a single folder within that drive.

If I go to sharing for the particular folder, I see the following message at the bottom of the window, and all options are greyed out;

"All the options on this tab are disabled because this folder is used by the operating system."

However, this is the case on this machine too, but I can still access the 'Program Files' folder on this machine from my other!

Hope someone can help.


Bablos.
 
B

Bablos

Guest
#7
Originally posted by Ninj0x
you cant share the programs folder, because it is used by the OS.
There must be a way, because I can access the 'Program Files' folder of this machine from my other one.


Bablos.
 

JJB6486

Retired Mod
Political User
#9
You need to disable Simple File Sharing.

Tools->Folder Options->View->Uncheck it at the bottom

Then set 2000-Style permssions for the folder. If you assign a global read to the SHARING permissions (thats the permissions button under the sharing tab, not the permssins tab, which is for local NTFS security) you can see every folder. The system and Program files lockouts are features of Simple File Sharing to keep dumb people from sharing and getting their System Directories deleted

JJB
 
B

Bablos

Guest
#10
Originally posted by JJB6486
You need to disable Simple File Sharing.

Tools->Folder Options->View->Uncheck it at the bottom
I've tried this, but Simple File Sharing isn't listed at the bottom - is this present in XP Home?


Bablos.
 
T

tens1on

Guest
#11
I read about this. Microsoft disabled file sharing of os protected files and folders which includes the program files folder. Fortunetly I beleive you are able to share folders within the program files folder.
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,013
Latest member
Pdawgintown