• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Ubuntu, Grub and my disk config don't get along

#1
Seriously, I don't think I've done anything wrong here, but it's killing me trying to figure out why Ubuntu's grub boot loader can't seem to figure out how to boot from my root partition. Suse does quite fine so I'm not sure what Ubuntu's issue is. Regardless, here's the rundown.

18GB SCSI drive, most of which is my windows boot partition. I've set aside about 125 or so MB of this to be my /boot partition. This would be sda2.

80GB HD on IDE1, all of which is windows stuff.

120GB HD on IDE2, of which about 13GB is dedicated to Linux. I have a 12+GB partition (hdb5) set as "/" and then 512MB as "swap".

So Ubuntu installs fine but when I go to boot to Ubuntu in grub, it complains of an error 17 saying that it can't mount the partition because it's of an unknown type (0x7, which is NTFS). So I look and it has "root (hd2,1)" as the first command in grub, which is absolutely the wrong partition. I use tab completion in grub to point it to the correct partition where "/" is located (I've also tried where "/boot" is) and it then throws up an error 18 saying that the cylinder is outside what my bios supports or something. I have the newest bios for my mobo (Asus A8N-E, A64 3200+) and haven't had any problems booting off these partitions previously. So I'm stumped. Anyone have any ideas? Perhaps using a map command in grub might work?
 
#3
oddly, grub counted my SCSI disk as disk 0 because of the way my BIOS is setup, I guess. Either way, I went back and tried again using 0,1 and it worked. Amusingly, I'd tried this very same config previously and it refused to boot so I'm not exactly sure what the deal is. Nevertheless it works now. Stupid linux :p
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,014
Latest member
chawalsub