svhosts process pinned at 99%

Heeter

Overclocked Like A Mother
Joined
8 Jul 2002
Messages
2,732
Hey all,

I got a machine here that has an svhost process that is pinned all the time at 95%.

It is the "svhost.exe - SYSTEM - 99 - 80,176(mem usage)" process.

In the Performance tab, the CPU is running at 100%, and the PF is at 384MB.

Needless to say that nothing is getting accomplished with this process pinned.


Once I end the process, everything runs very very good.

I ran a spybot, nothing to write home about was found in the scan. I think that I will run an AVG scan as well.

I did notice that when I stop the service the theme of XP resorts back "Classic". Maybe someone installed a bad theme in this machine.

Any ideas as to why this is happening?

Thanks,

Heeter
 

fitz

Woah.. I'm still here?
Political Access
Joined
26 Apr 2004
Messages
4,085
hey heeter..

note the PID of the svchost process and run "tasklist /svc" from the command line. It should show you which services are using that particular svchost process (match the ProcessID)

My first guess would be windows update process..
 

madmatt

Awesome is as awesome does.
Political Access
Joined
5 Apr 2002
Messages
13,314
It may have something to do with KB927891. It is said that the latest fix isn't working.
 

fitz

Woah.. I'm still here?
Political Access
Joined
26 Apr 2004
Messages
4,085
yup.. that would be one of the reasons I suspect the windows update service. But you should check to make sure the windows update is running off that svchost process (using tasklist) before uninstalling the client. :)
 

Heeter

Overclocked Like A Mother
Joined
8 Jul 2002
Messages
2,732
Okay The PID is 1092

What do I write in the command line? I am kinda lost at this stage.

I followed the KB link and updated and it is still doing this.


Heeter
 

Attachments

  • untitled.JPG
    untitled.JPG
    88.4 KB · Views: 74

fitz

Woah.. I'm still here?
Political Access
Joined
26 Apr 2004
Messages
4,085
drop to a command prompt

type: tasklist /svc

It will display a whole bunch of info on all the processID (PID) running. Find the one that matches the svchost process (in your case 1092 - at least until your next reboot) and note which windows services are handled by that instance of the svchost process.

report info back here :)

edit: screenshot example attached
 

Attachments

  • Untitled.jpg
    Untitled.jpg
    50.7 KB · Views: 82

_kC_

OSNN Senior Addict
Joined
10 Jan 2004
Messages
514
go to ie/tools/windows update

do you use microsoft update? if so thats the cause.... revert to "windows update"

if so click on change options and click "remove microsoft update"
 

Heeter

Overclocked Like A Mother
Joined
8 Jul 2002
Messages
2,732
Duh, forgot the space between the words...

Now it is service PID 1088

This is what I got:
 

Attachments

  • untitled.JPG
    untitled.JPG
    57 KB · Views: 69

Heeter

Overclocked Like A Mother
Joined
8 Jul 2002
Messages
2,732
go to ie/tools/windows update

do you use microsoft update? if so thats the cause.... revert to "windows update"

if so click on change options and click "remove microsoft update"

How/where do I change options, can't see it.

Thanks,

I think that might be the problem as I open Microsoft update and the machine is locking up again.

Thanks,

Heeter
 

_kC_

OSNN Senior Addict
Joined
10 Jan 2004
Messages
514
on the microsoft update page, on the left menu, click "change options"
then in the main window scroll down...


should be a tick box at the very bottom "REMOVE MICROSOFT UPDATE"

do that and reboot.. hey presto.. your fixed:)

have had 200-300 of these probs in our workshop and on callouts in the past few month
 

_kC_

OSNN Senior Addict
Joined
10 Jan 2004
Messages
514
yeh then the 99% will just restart when the service restarts..

just remove the microsoft update and its solved for good
 

Heeter

Overclocked Like A Mother
Joined
8 Jul 2002
Messages
2,732
Funny thing, this machine doesn't even use IE, it has FF as default.


Oh well,

Heeter
 

Members online

No members online now.

Latest profile posts

Xie wrote on Electronic Punk's profile.
Impressed you have kept this alive this long EP! So many sites have come and gone. :(

Just did some crude math and I apparently joined almost 18yrs ago, how is that possible???
hello peeps... is been some time since i last came here.
Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.
Terrahertz wrote on Electronic Punk's profile.
Yo fellas!
Electronic Punk wrote on Sazar's profile.
Where are you buddy?

Forum statistics

Threads
62,004
Messages
673,460
Members
5,599
Latest member
Larry Chris