• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Stupid external hard drive

Kitmeow279

OSNN One Post Wonder
#1
Dear people,

Please help! I bought a 250 GB external hard drive so that I can move ALL my music files and iTunes there, so as not to clog my measly 60GB built-it hard drive. Well, turns out that iTunes can't run from the directory where it's installed, it must use up a folder in MyDocuments to store all its stupid music files.

Well, OK. I said forget it, and decided to use the external hard drive for storage and backup purposes only. When I went to unplug the darn thing I went to the little icon near the clock (at the bottom right of the screen) and clicked "safely remove hardware". A window popped up and told me that the hardware is in use and I can't remove it.
So like an idiot I went to device Manager and set the stupid thing to "disabled", and then safely unplugged it.

The problem is...... when I go to plug it back in the system tells me that I plugged in a "mass storage device" and that's it! It doesn't show up in device manager at all! It dissapeared!

What to do? I am ready to take a hammer to it!

Please help!

P.S. I use Win XP service pack 2 on an Acer laptop
 
Last edited:

Xie

- geek -
#3
Well, turns out that iTunes can't run from the directory where it's installed, it must use up a folder in MyDocuments to store all its stupid music files.
You did go into iTunes and change your music folder location right? Go Edit -> Preferences -> Advanced and it's the 1st thing. :)

:edit: - Oh and does the external HD show up in Drive Management?
 

Kitmeow279

OSNN One Post Wonder
#4
ok, never mind the iTunes thing.. That program is the worst for getting on my nerves.. I'm just not going to bother...

But.... There's still the hard drive issue. AFTER i've used the hard drive and put all sorts of stuff on it (music, pictures, games) I went to device manager and right-clicked and disabled it. I chose the option that says "do not use this drive" instead of "use this drive"
and since then it NO LONGER shows up in device management

So how can I set it to "use this drive" if I can't see it in device manager?

Thank you
 

bush dogg

OSNN Senior Addict
Political User
#5
I think your going to have to enable the drive again in “removable storage” to do that try this…

Click start right click My Computer select manage expand removable storage (click the plus sign) then expand libraries then right click the external harddrive and select properties, on the general tab at bottom of page make sure there is a check in the box at “Enable Drive” after this you should see the drive again.


Next time you want to “safely remove the drive” and get the “ Hardware is in use cannot remove drive” message then the drive may be still working after a large file transfer, but that happens a lot with external devices including card readers. “At least I have that happen a lot”

The best thing to do in that situation is wait a few hours and try again or just shut down and disconnect the drive/card reader at that time.
 

Kitmeow279

OSNN One Post Wonder
#6
Wow that was excellent advice, Thank you so much!

It is true.... unplugging and replugging isn't ALWAYS the right solution.. sometimes a person DOES have to dig deeper.
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,016
Latest member
ernestrojasn