• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

SP2 update broke Explorer


Debiant by way of Ubuntu
A day or two back I was given an old XP1200+ low-profile system, because it matched a 1900+ I had and thought I could use it to resolve BSODs on the 1900.

Anyway, it was reset to factory settings (both machines have XP home OEM'd onto a hidden FAT32 partition), this I think was at SP1 level. So I put AV in place and installed drivers and added dongle for my wifi and got Adaware and Spybot in place since factory setting include all this Surfairy spyware crap, and then went to get updates. At first it said to go straight to SP2, but that failed (twice) with a Red cross "Invalid data". After that I want to custom update and applied all I could find before SP2. This seemed to enable SP2 to go on via donwload, but I now find afterwards that both Explorer and IE and, incidentally DrWatson if I try to report the error are all collapsing.

Needless to say the system is less than useable. To make matters worse when I try F8 for safe mode it gives me the boot devise choice, so I am not sure which key to get to safe mode (going to try DEL now).

Anyone any ideas beyond going back to pre-SP2 and trying again? (I do not like trying the same things because I EXPECT the same result with computers!). I have tried running SFC /Scannow with no joy. I cannot get into IE to try repair there.

Remember I do not have an XP home CD, these being OEMd so I cannto get to recovery console (unless you are allowed to do that with XP Pro, I have a cd for that? But I think that's a no no).

I had a couple of niggles with SP2 - but this is an impressively bad experience! Must be something unusual, would have heard more about it if this was commonplace.

[EDIT] I really should have mentioned that even before SP2, IE right from the reset (or as received) I was getting occasional Registry file recovery dialog boxes, telling me the file had been recovered and I was clicking OK. My guess is origins of problem lie here, though I holpe SFC would fix. Anyway restoring pre-SP2 hoping to resolve and rerun SFC, this time BEFORE applying SP2 - unless anyone has better ideas out there? [/EDIT]


Debiant by way of Ubuntu
OK I just redid all my steps but with the additional registry cleaning and SFC - end of process = exactly the same story.

Anyone else got any ideas? Looks like I'll just be running SP1 here - until I get some idea what to try (I think my next step will be to try from the CD, when it comes or I get hold of one from another source).


Debiant by way of Ubuntu
damn - you're offline - hope I can catch you in IRC... I said in my post I ONLY have a PRO cd - do I have to buy a HOME CD? Bit of a rip off when I had it OEMd in there.... thinking of using this as a linux box now (since it's just a 1Ghz Duron and 20GB drive anyway)


Glaanies script monkey
Political User
download SP2, burn it to a CD, do the repair installation and install SP2 via the CD before connecting it to the internet.


Debiant by way of Ubuntu
errrr how do I do a repair installation without an XP CD? I only have a Pro CD and on this machine is Home on an OEM hidden partition. I am (almost) certain you are right and know what you are suggesting - what am I missing?
just do a clean install with your pro cd and use your pro key - its not strictly legal but I assuem you purchased your procd so you dont have much to worry about - if needed I can "assist" ;)


Debiant by way of Ubuntu
BUGGER I would like to be strictly legal and more importantly stay inside forum guidelines....


await wrath of mods and fancy effects and stuff...

PS Don't it do stuff with registering with M$ and your NIC card and various MAC addresses...?

PPS MAybe you should NOT answer that ?


Debiant by way of Ubuntu
this is surreal - I did a clean install and format - no more hidden partition or anything...

get right up to SP2, install it (OK from automatic update, not from CD) and THE SAME THING HAPPENS!!! What gives? If it were the way I am doing this it would hit lots of people - I'm working to burn a CD now like JJB said, but at the same time I am wondering - should I be looking at the BIOS in there?

Or are there any other ideas?

I did notice that right after the clean install of XP it came up with that message again about replacing a copy of a registry file with a good one from a copy - no idea if that indicates anything. Running an sfc /scannow right now, but doubt this will crack it and going to have to go back via system restore....


Boot to dos with a windows Me or lower boot disk, do a fdisk to remove the partition o.e.m. suppliers stick windows on, then set bios to boot from cd rom, put in sp2 xp disk and run from there.


Debiant by way of Ubuntu
j79zlr said:
Just install FreeBSD, its trying to tell you something.

Really I'm not sure whats going here.
I think this is the one I am most tempted to follow! Seriously though, the hidden partition is history and so what Lee said should not be required - I only have the one SP1a disc at the moment, having troubles with download for the SP2 and not made a slipstream yet... this is strartig to bug/intrigue me because I do not like to give in easily.

Also need to be sure I can get drivers for my wireless USB dongle before I move away to freeBSD or Linux or anything....

So - having used system restore to bring back my SP1A functional system - I am wondering what next still.... Only additional info I can add is that the previous owner was seriously insecure and had some major infections - but to my knowledge nothing can penetrate to BIOS? Plus I did a full format putting XP back in and taking hidden partition out....

Running out of ideas - but will post if I ever solve it.


Debiant by way of Ubuntu
Yay - when I finally got the sp2 complete shebang on the machine it worked.... so this problem was a result of some sort of borkage in the auto update route (which M$ recommends?!).

Now I just got to tidy up and DriveImage and then figure out what I want to DO with that Duron.... ;) :)

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
What a long strange trip it's been. =)

Forum statistics

Latest member