• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solution for Vista folder issues (losing folder views)

Dark Atheist

Moderator
Staff member
Political User
#1
WARNING: The exact cause of Vista losing it's memory on your folder view settings has not been found yet. This will just reset them for now to help Vista remember them again. It has been noticed that changing a lot of window folder view settings in combination with some unknown applications settings may be triggering this forgetfulness. Make sure that you do not have a setting in a 3rd party program set to clear the folder view setting cache when it is used. (EX: CCleaner - Window Size/Location cache option under Cleaner -> Advanced)

Reset Folder View Settings :

1. Open the Start Menu.
2. In the white line (Start Search) area, type regedit and press Enter.
3. Click Continue for UAC prompt.
4. In regedit, go to:
HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags

5. In the left pane, right click on Bags, and click Delete.

6. Click Yes to the confirmation pop-up window.

7. In regedit, go to:
HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\BagMRU

8. In the left pane, right click on BagMRU and click Delete.

9. Click Yes to confirmation pop-up window.

Increase Folder View Cache Memory :
NOTE: This will increase the amount of folders to be remembered for changes to the folder view settings.
OPTION: This is a optional step, but the increase will help ensure that Vista does not forget. Steps 1-9 must be done first before you do this section. If you decide to skip it, them go to step 13.

10. In regedit, go to:
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell

11. In the right pane, right click on BagMRU Size.
23. Click Modify.

12. Dot the Decimal and type 20000 (folders) and click OK.
NOTE: 5000 is the default number of folders to be remembered.

Wrapping it Up :
13. Close regedit.
14. Logoff and logon,or restart the computer to apply the reset and to let Vista rebuild the registry keys with a clean slate.

Source:

http://www.vistax64.com/tutorials/70819-windows-explorer-folder-view-settings.html

I have tested this and it does to seem to work so far :)
 

ming

OSNN Advanced
#4
this has been the case since Windows XP and possibly earlier version for me. Change the view in a sub-folder (3rd or 4th level) and the view on 'My Computer' changes as well, but not any other sub-folders.
 

epk

Moderator
Political User
#8
hehe.. i just looked this up on google last week :]


yeah, they should definitely fix it
 

agptek11

OSNN One Post Wonder
#9
WARNING: The exact cause of Vista losing it's memory on your folder view settings has not been found yet. This will just reset them for now to help Vista remember them again. It has been noticed that changing a lot of window folder view settings in combination with some unknown applications settings may be triggering this forgetfulness. Make sure that you do not have a setting in a 3rd party program set to clear the folder view setting cache when it is used. (EX: CCleaner - Window Size/Location cache option under Cleaner -> Advanced)

Reset Folder View Settings :

1. Open the Start Menu.
2. In the white line (Start Search) area, type regedit and press Enter.
3. Click Continue for UAC prompt.
4. In regedit, go to:
HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags

5. In the left pane, right click on Bags, and click Delete.

6. Click Yes to the confirmation pop-up window.

7. In regedit, go to:
HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\BagMRU

8. In the left pane, right click on BagMRU and click Delete.

9. Click Yes to confirmation pop-up window.

Increase Folder View Cache Memory :
NOTE: This will increase the amount of folders to be remembered for changes to the folder view settings.
OPTION: This is a optional step, but the increase will help ensure that Vista does not forget. Steps 1-9 must be done first before you do this section. If you decide to skip it, them go to step 13.

10. In regedit, go to:
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell

11. In the right pane, right click on BagMRU Size.
23. Click Modify.

12. Dot the Decimal and type 20000 (folders) and click OK.
NOTE: 5000 is the default number of folders to be remembered.

Wrapping it Up :
13. Close regedit.
14. Logoff and logon,or restart the computer to apply the reset and to let Vista rebuild the registry keys with a clean slate.

Source:

Windows Explorer Folder View settings - Vista Forums

I have tested this and it does to seem to work so far :)
Let them more and more easy
 

Members online

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,014
Latest member
sanoravies