• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

[Slackware/Xorg] Can't start startx (X-Window manager)

#1
I need help again, guys and girls! For some reason, I can't startx anymore in my Slackware 10.0/Xorg environment. I checked the logs, but there is nothing in there, only the last time startx worked. When I enter startx, nothing happens, literaly, I have to press CTRL+Z to cancel it. I first thought it may be related to some new progs I installed yesterday (MySQL 4.1 (wrong version, DOH!) and Apache2), maybe they are caught in some sort of loop upon startup, but all of the non-X programs still work, like elinks, in which I am typing this message.
All I did yesterday before breakdown of startx, was compiling MySQL 4.1 and Apache2 from source and installing them. I have made sure they didn't overwrite files in the X11 dirs or sump, so that just can't be the cause.
Although it's funny to browse the web in a textbrowser, I want my X back. A little help here is appreciated :)
 

mcmonkeys1

OSNN One Post Wonder
#3
hmm, yeah, well i'm not so lucky. slackware 10.0 boots up everything seemingly normal. type startx, hit enter, and absolutely nothing happens! tried xwmconfig for other window managers, no effect. reboot, nothing. so i said maybe i'll try reinstall X from dvd or something, but NO!
'mount' refuses to do anything at all either! a blank line, i have to control-c out of again! ??? seems like nothings working.
anyone any idea what's going on? don't recall installing anything or changing any settings. i did recently installed kde and kde seems to crawl along every now and then, but that's been going on for a while now. the only other unusal thing is that i've never bothered with swapspace partition or file. my system ram is never even close to being fully utilized (756mb), highest was around 256mb, and only under kde with other apps. i'm an XFCE fan anyhow. if it ever is used i'll add a swap file. as u may tell i'm a bit of a noob, isn't everone in a way, but i'm willing to put the time in.

thanks for any replies.
 

mcmonkeys1

OSNN One Post Wonder
#4
figured it out. don't know the reason behind this, but if the network is not set up correctly this occurs (or rather things don't occur).

scenario 1: network with static ip address', no nameservers, DHCPservers, etc, just "/etc/host" files. if the laptop is using DHCP the anomally occurs.

scenario 2: laptop has static ip address set. anomally occurs when attached to DHCP driven network.

Go figure?? anyone any insight as to why this occurs?
0
 

Members online

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,016
Latest member
ernestrojasn