• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

secure digital card malfunction (not recognized?)

logisticprism

Time Dr. Freeman?
#1
I have an SD card from a camera that my cousin tried in his computer and it worked initially, but then when he put it in later it says "please insert disk." I tried the card in both my mac and PC. The card won't mount on my mac, and it gives me the "please insert disk" message on my pc. If i put the card back in the camera, the camera will read no pictures. Any ideas or suggestions on how to recover the pictures on this card? The camera is a konica minolta dimage f300, and i have a lexar card reader with a san disk sd card.
 

zeke_mo

(value not set)
Staff member
Political User
#2
Try putting the card in the camera and formatting it. IF that doesnt work, try connecting the camera to the computer directly.
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,962
Messages
673,240
Members
89,018
Latest member
timpage