scanner working, but not working?



Hello everyone,
I'm not sure if I should be here or on the driver forum but here goes.
I have installed my scanner numerous times b4 but now it refuses to work as it should. Scanner is Canon FB630U , OS is XP pro, 2 user id's, me and wife both as administrators. If I install scanner logged on as me, the TWAIN driver only works for my user and not my wife.This happens vice-versa for my wife. I know it is a twain driver problem because even though the device doesn't work "for the other user" it is recognised by windows and test's OK. Using any application to scan, reveals that no twain compliant device is listed. I can't install the scanner again "for the other user" as windows refuses to do this , I'm guessing because it is already installed correctly. Is their some way to install the twain driver manually . The twain driver is installed in the C:\windows\twain_32 folder as it always was on all other installs.
latest canon drivers installed etc.
I regularly check for OS updates and install them as needed but havn't installed SP-1, coz I've read to many bad reports at the moment
can anyone help?

Hipster Doofus

Good grief Charlie Brown
Have you got the latest drivers for xp? Is this the first time you have installed it on XP? If your system is up to date you should give sp1 a go. Some have had problems but many suffered no ill effects at all.


I've had it working on another system, before it had to be replaced with my current box . Latest canon driver for XP (the driver date is rather old but worked for me b4) is installed and I had archived this driver before I built the current system to reuse it here.
Like I said earlier the scanner works perfectly if I log on my wife's identity but not for me , because I installed the scanner while logged on as her. (Wife uses the scanner more than I) I would like to get it to work as it should , and has done b4. I have had the current system running for 2 months now , but never needed to scan so I cant say for sure if it's related to the current system or what .
Definitely twain driver related which for some reason is not being recognised correctly for my identity.
my system is working well so I'm not that keen to load sp-1 yet mybe with my next upgrade.


Hi djwhite,
yeah I was probably trying that as you were typing your reply . Unfortunately all that achieves is to ' cause an error while writing driver files to disk ' or some crappy explanation from windows, making the scanner not recognised by windows. Then I have to log on as the user who originally installed the scanner to update the driver again or re-install it as happened on one occasion as it wouldn't take.
thanks for your input too! I just found another problem too. Using the windows 'Scanner and Camera Wizard' doesn't work for either user , I thought that only happened to me (currently) i wonder if this has anything to do with this problem.
the error says ' the computer cannot detect the camera or scanner' .I also have a webcam, and this works via the 'Scan-Cam-Wiz'. How can the computer not detect a scanner that works perfectly for the user that installed it ?


The scanner wizzard only works for scanners with the windows based drivers (.wmi or something) not for installing twain drivers, so don't worry about the wizzard.

As for the installation - since the scanner works for one account there's nothing wrong with the drivers per se .. but they are being set up (obviously) on a user specific basis ... try rightclicking on the setup file and select "run as" ... then select "administrator" add admin password and install the drivers that way.

That has worked for me on other apps that haven't recognized me as an administrator even though i'm the only admin user on the pc.



Thanks for your input, Blue, the only problem is that the driver files have no setup.exe file . They came off the Canon web site and only contain the driver files. You have to install/update the driver using the device manager routine. I think I'm giving up on this scanner as it's gonna be easier to get a new model scanner than to have to re-install Xp and see if this fixes it. I do have another hdd that I currently use for backup-archive purposes I'm thinking of using as a temporary "new install of Xp (maybe with sp-1)" to see if this will get it working . Maybe next weekend with some time up my sleeve. Has anyone had two copies of Xp on one computer on two different hdd's. I'm guessing both hdd's should be set to master on separate ide channel then set bios to boot from that ide. Sounds like it should work yeah?
What really doesn't make sense is that the twain driver is in the 'C:\windows' directory which doesn't make any difference as to which user is logged on, the driver is accesible to the computer at all times, as are the system drivers for it , in 'c:\windows\system_32' folder .


Hi I'm back. I need access to a registry editing expert!
I've checked the registry everywhere I can think of and in the process I've discovered that there was an enormous difference in one of the software keys under Canon, between mine and my wife's account. But I'm buggered if I can see anything to do with the Twain Driver in the registry to compare the two settings. Does anyone know 'an awful lot' about the regisry or some links?
I did copy my wife's settings of that key and used it on mine , but this didnt work :mad:

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
What a long strange trip it's been. =)

Forum statistics

Latest member