• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

samba wont start

Dark Atheist

Moderator
Staff member
Political User
#1
carp-serv# ./samba start
Removing stale Samba tdb files: . done
Starting nmbd.
Starting smbd.

now i have done a few things from here (all near enough) to help harden it up
http://www.linuxquestions.org/questions/showthread.php?p=3062672#post3062672

i have checked that the /var/run and /var/log dirs are 755 which they are, and i have also rechecked the smb.conf file which is a backup of a known working version on linux and bsd.

nmbd starts and writes its pid to /var/run fine so i am at a loss as to why smbd wont start.

Have googled for about an hour now reading many a mailing list and there is not one post like mine :( - i have ran smbstatus and got

carp-serv# smbstatus
sessionid.tdb not initialised
/var/db/samba/connections.tdb not initialised
This is normal if an SMB client has never connected to your server.
Failed to open byte range locking database /var/db/samba/brlock.tdb
ERROR: Failed to initialise locking database
Can't initialise locking module - exiting


i hve checked and that file is not there, i have uninstalled and recompiled samba, and that hasnt helped, could it be all the steps i did to harden FreeBSD have caused this ?

Although ftp and web work fine :rolleyes:
 

Dark Atheist

Moderator
Staff member
Political User
#5
yes they are all set to 755 and owner/group is samba - im begining to think it may very well be all the things i did from that link on linuxquestions.org BSD forum as ftp is being a tit atm, i think i may well just wipe the sys - install the pf rules and leave it, people will have to get past the router and then openbsd pf if they wanna get into it, and the people who will be using it are flids and can hardly use windows so they pose no threat to me :)
 

Dark Atheist

Moderator
Staff member
Political User
#7
carp-serv# testparm
Load smb config files from /usr/local/etc/smb.conf
Processing section "[home]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
workgroup = PHOENIX
interfaces = nfe0
bind interfaces only = Yes
socket options = TCP_NODELAY SO_RCVBUF=16384 SO_SNDBUF=16384
printcap name = cups
hosts allow = 192.168.1.
hosts deny = ALL
printing = cups
print command =
lpq command = %p
lprm command =
hide dot files = No
locking = No
delete readonly = Yes

[home]
comment = Home
path = /home/carpo
valid users = carpo
read only = No

nmbd starts smbd doesn't, i think it is the perms and stuff i did from dr deaths post on linuxquestions have secured it a bit too well, and i have permd something up wrong.

think i will wipe it later and leave off the tweaks and run it as is :) - i think i shoukld have installed everything first then apply those changes, easiest thing will be a wipe and re-install. Thanks to all for their help
 
Last edited:

Dark Atheist

Moderator
Staff member
Political User
#9
nothing in there apart from the msg the service has started

[2008/03/25 17:49:08, 0] nmbd/nmbd.c:main(697)
Netbios nameserver version 3.0.28 started.
Copyright Andrew Tridgell and the Samba Team 1992-2007


[2008/03/25 17:49:08, 0] smbd/server.c:main(944)
smbd version 3.0.28 started.
Copyright Andrew Tridgell and the Samba Team 1992-2007

is all they show
 

Dark Atheist

Moderator
Staff member
Political User
#10
carp-serv# ./samba start
Removing stale Samba tdb files: done
Starting nmbd.
Starting smbd.
carp-serv#

after a reinstall its working - after a lot of reading elsewhere it comes down to either the settings i did from linuxquestions.org, or the pf rules i had as it looks like not all packages were coming down, so i could have been missing libs, still least it all works now :)
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,013
Latest member
Pdawgintown