Raid 0 - very slow write time




I was having a slow performane while copying files using win xp.
I have 2 60 gig ibm deskstar 7200 rpm Hard drives on Raid 0.

To copy a 250 meg file takes approx. 18-20 seconds.
I got sandra and ran a benchmark "using" the windows disk cache.

My read speed is great around 80 MB/Sec but my write speed is only around 10 MB/sec.
If I disable "use the windows disk cache" during the test it compares well and writes well.

So the hard drive and raid controller itself is not the problem.
It must be windows. Sandra suggested I make sure "write verify" is turned off. How do I do this??
Any other suggestions welcome.

Oh yeah it copied 250 meg files about 4 days ago in about 4-5 seconds.
I also ran defrag 3 times, no difference.

Thanks for any input - Tfp
What have you done in the last three days? What mobo are you using? Im getting 80 buffered read and 77 buffered write on a single 7200 wd on master ide. Are you sure your configured correctly?Whats running when you benchmark with sisandra?
Maye one of the drives are the ones that like to play dead.
On a raid 0 set up one dead all dead. I dont think he is configured correctly.
I am using a KG7-raid,

programs running were the normal windows background stuff.

When I run the benchmark in sandra if I check bypass windows cache in the options menu it works fine. But when I unclick it and use windows cache with the test then I get the low write speed.

I am not sure I am configured correctly. I dont know where to do this.

When I go into the raid setup on boot the drivers are set to the 5 mode.

sandra says "ata u100 2x raid0 7200rpm 40 gb" drive index is 36300.

while mine is only 1539

I can't really remember what I was doing in the last 3 days, I install stuff all the time.

I noticed it when I was using direct connect. I was copying files in progress and pasting them so I could view them. Then on one of the copies the time it took to copy just got noticbly longer.

Is it normal to take 20 seconds to copy a 250 meg file??
First you need to run sisandra with no programs running and disconect from the internet. Thats the only way to get a true measurement.Did you install the hardrives yourself?I believe each drive should be on its own ide and you would have to go to the manufacturers web site to see where to place the jumpers on the back of the hd.Normally they should each be master however wd on a single ribbon needs to be neutral so you must check. Also are you using 80 pin ribbon? Does your mobo have promise ide?
There are a bunch of different jumper settings on the back of the drive. I installed the drives myself onto their own ide controller.

Drive 1 is on ide3 drive 2 is on ide4 both with 80 pin cables that came with the drive.

No promise IDE. I have a highpoint raid controller built into the motherboard.

I just ran the test again without the windows cache and it is much much slower than before.

I will close all programs and internet and run them again.

Right now the jumpers are set to cable select.

There are 4 menus:
16 head
15 head
32 GB clip
auto spin disable.

And they all have these options:
device 0 (master)
device 1 (slave)
cable select
forcing dev 1 present

Currently they are both set to 16 head cable select. I just did this 4 hours ago, before that they were set to 16 head master.

Thanks Doc
I would install as follows (unless ibm says otherwise) Primary Ide 1 hd jumped to master. Secondary Ide 1 hd set to master. You must make sure your bios is set to raid. Look in your mobo manual,it should take you through it step by step. Or on their website they will have directions. Also you may have to jump the raid controller on. If I had the mobo I could help a little more.
Yeah I changed them back to master and I still test slow.

Oh well, maybe the cables are wearing down.

The first time I did the test it measured right up there with what it should be then i checked use windows cache and now even with the first test i ran the speed is worse than a ultra 66 raid 0.

Yeah all the other stuff is configured in the bios.

Maybe it will come back someday. Not to big of a deal I guess, except it isnt what I paid for.

Thanks for the help Doc - Tfp
You need to be on primary and secondary ide. Whats with the windows cache??
I have a primary ide a secondary ide and 2 others dedicated for the raid.

Raid actually wont work unless on thoce ide slots.

The windows cache is in the test. I am not exactly sure what it is, that is what I am trying to figure out. I think that all data goes to the system cache and then goes to the hard drive.

Dont really know, It also says that I should make sure "write verify" is off. when i include the windows cache in the test.
You've hit on an issue that a lot of people dont even realise they have. Everyone I know has experienced a drop in hard drive performance since installing XP.
My recent discovery (and a few other people too on these forums) is that write cacheing appears to be disabled on some systems despite it being reported as enabled in the Hard Drive properties.

As I only discovered this a few days ago, I havent had chance to research it fully. No doubt a lot more information on this is going to come to light soon as this topic appears to be picking up momentum.

BTW, the way I found it was disabled was to run BootVis from Microsoft - the utility that speeds up your boot times. This utility reports to me that write cacheing is disabled upon reboot, after running the 'Next Boot + Driver Delays option'.
My write cacheing option in the properties of the c drive is greyed out, Is yours also??

I also found another guy to test his write speed and it took him about 13 seconds to copy a 250 meg file on his hard drive.

How long does it take you to copy a 220-250 meg file??
Yeah, my options are greyed out too. I'm not sure if thats meant to say you cant change these or whether they arent the valid setting. Seems strange to grey them out.

I get almost exactly the same result, but this isnt a test of Drive cacheing, using a file of that size will tell you the sustained throughput.
Burst (cached) transfer rate is not easy to measure by doing file copies - you need much smaller files, but you could glean something from it. I would use HDtach to check my write performance but you need to have a blank drive to test this with it :(

Does anyone know of a shareware tool that is good for accurate write tests without needing a blank drive?
disabling the paging executive isnt anything to do with cacheing.
Can I ask why you think this will have any effect?

Hard Drive Write Cacheing is the ability of the OS to defer writes to the hard drive and allow ongoing system processes, writing to the hard drive when the drive is ready to receive the data.

Disabling the paging excecutive will prevent the OS from putting the unused parts of the Kernel that are already in the system Memory, to the swap file.

If you can explain the link, I would be grateful.:confused:
Originally posted by Tfp
There are a bunch of different jumper settings on the back of the drive. I installed the drives myself onto their own ide controller.

Drive 1 is on ide3 drive 2 is on ide4 both with 80 pin cables that came with the drive.

No promise IDE. I have a highpoint raid controller built into the motherboard.

I don't recall if I saw it on this forum or on the Sharkey forum, but it seems there may be problems with onboard highpoint controllers and RAID 0 when going to XP. I'd check with your mobo vendor for new drivers (BIOS, chipSet, controller).
I'd also double check your BIOS settings for mismatches on channels 3 and 4 (DMA v PIO, etc). Also check for mismatches in XP Device Manager.

Members online

Latest profile posts

Also Hi EP and people. I found this place again while looking through a oooollllllldddd backup. I have filled over 10TB and was looking at my collection of antiques. Any bids on the 500Mhz Win 95 fix?
Any of the SP crew still out there?
Xie wrote on Electronic Punk's profile.
Impressed you have kept this alive this long EP! So many sites have come and gone. :(

Just did some crude math and I apparently joined almost 18yrs ago, how is that possible???
hello peeps... is been some time since i last came here.
Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.

Forum statistics

Latest member