• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Quake III Arena & WinXP Mouse Problem



When I play Quake III Arena offline, everything works fine, but when I play it online, its unplayable simply because the mouse has got a mind of its own... i run forward and all of a sudden im looking at the floor or at the ceiling or it simply shifts to one side... its a proper annoyance when im fighting someone and it just jumps to miss the person.

ive tried both a usb (the prefered mouse) and a ps/2 mouse also. ive turned off the mouse precision, changed sensitivity and also toggled the m_filter command in Q3 but with no success :(

anyone got any ideas?

piii 733 fcpga
ibm mobo (god knows what it is, i cant even find it on the ibm website using the product code!! but its got an intel 815 chipset)
128mb RAM
8mb Nvidia Vanta
PCI 128 Soundcard
Netgear FA311 NIC (connected to cable modem)
Realtek 8139-Series NIC (connected to Xover cable to 2nd pc)


Try this , i have never had the mouse issue, but this is meant to fix it.

BACKUP your registry First :)

1. Copy and paste the code below to notepad

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Control Panel\Mouse]

2. save it as mouse.reg

3. Right click on it and choose merge , then click ok

4. Reboot your computer


mouse problems.

I had simular problems with the MS Intellimouse Explorer..
I just turned mouse settings really low in game and used the command /in_mouse -1 , then /in_restart and that seemed to make it at least playable.
Since then Ive got a logitech (with the Gamer Registry Patch) and have had no problems [=


I have the exact same problem and have since loaded Windows98 to fix my prob! I would really like to get back to using one operating system like XP.

I was wondering if that REG mod fixed your problem? Let me know as I really don' t like jacking with the registry if its not going to fix my problem!


So no one has tried this mouse reg fix? I did install the latest MS Mouse drivers and it did improve it a bit but it still not as solid as Windows 98SE


the server hosting the game might have odd settings, does it happen with every server, or is it only one... otherwise, might just be lag...
or driver issues


RE: REG Mouse Fix

Sorry It took me so long to reply, I was gone for several days sturgeon fishing [=
I had several problems with the MS Explorer. Sometimes not wanting to move at all, sometimes not wanting to go the right direction. and most of the time I noticed that when it was happening it was in quake3.
Turns out it wasnt any setting, registry problem, or any of that. It was the damn light. Ive had 2 MS Explorer mouses in the past year and both of them have already had the light flake out and die.
My opinion get Logitech.
as far as settings for the mouse (if it is working correctly)
the best that I found was /in_mouse -1
no accel in driver. Low sensitivity.

I included my q3config for you so that you can get a idea of how to use mouse accel in game as opposed to using the driver. which the MS mouse never worked for me anyway.


sooo, let me see if i got this straight...
i have an microsoft wireless weel mouse - i know it's not very good for gamming.. - and sometimes it moves like.. 2 or 3 inches.. by itself!
should i get a logitech instead?
also, it seems unable to be precise.. it looks as if it jumped some pixels..
help anyone? :(

Sm|th 6th

Explorer is an excellent gaming mouse... that is not the problem. The problem is eithe in your config or your system. I play in many q3 tourneys etc etc And most guys I know use either the microsoft explorer, boomslang or logitech wingman. Of course there are others but these ones dominate.

These are my mouse settings for q3

// Mouse setup
// Razer BoomSlang 2000, driver sens=7, acc=0.05, no x/y difference
seta in_mouse "-1"
seta sensitivity "12"
seta cl_mouseAccel "0.05"
seta m_forward "0.25"
seta m_pitch "0.020"
seta m_side "0.25"
seta m_yaw "0.022"
seta m_filter "0" // no artificial smoothing
seta cl_freelook "1"
seta in_joystick "0"


Thanks for the replies guys! I have tried the /in_mouse -1 and had no luck. I did download the latest drivers from MS for the MS mouse and it seemed to fix it somewhat but there is still an annoying lagging type problem. I know its not lag as I am watching the lag meter. I went out and got a Logitech dual optical and noticed it did not work with my RatPadz:( Dam I can't win one! The mouse kind of gets confused on this surface. I have not had a chance to play the game yet as I have been too busy working on the yard! Damit I hate spring. I will try and get a game in tonight but if it fixes my problem I sure will be relieved as I never have this problem when I boot into 98SE. I will have to find another solution for a mousing surface as I really go used to my RATPAD!


according to a review in tom'shardware:
Logitech claims that this makes the mouse less sensitive to different surfaces and that it improves accuracy because it's never in a situation where data is lacking. In fact, the Dual mouse can be used on any kind of surface - even a translucent grey plastic folder with a slightly raised grid pattern on the surface did not hinder its performance, although its rivals threw in the towel.
so.. it really is bad luck!:(

if u wanna see the rest of it:


Man I am going to kill someone! I have tried everything I can possible think of! I have disabled Mcafee, Zone Alarm, updated the MS mouse drivers for the Intellimouse pro and still this jerkiness is happening. I have tried all the suggestions from everyone above with no luck! I know several peeps that have XP and are playing Quake and other games and are not have this problem. The only other thing I can think of is repartioning my Hard Drive and install a second installation of XP and install Quake from scratch and see if it still happens! The worst part about it is that it is a system gaming wide issue. I have Max Payne and am exeriancing the same problem. I have tweaked my config, turned of acceleration you name it! It still is unplayable


The mouse I am using is a MS Intellimouse Pro with a mouse wheel. They discontinued them when they came out with the Intellimouse Explorer optical. I think it was the first wheel mouse they came out with. It’s a PS2 mouse but it came with a USB connector. I have tried the Logitech dual optical and I get the same results.

The jerkiness I am talking about is random but occurs frequently, so much that it makes the game unplayable when online. I have had a hell of a time trying to pinpoint this problem. Oh and to answer your question its "Unevenly"!

Thanks for any help you guys can give me!



No clue on this one, I was thinking that maybe it was your vid card, but in that case it would have been even jumps right?


this may sound crazy

but i had the same problem for awhile, and i noticed something happening at the same time, which sounds strange: other people were coming into my game and taking over control temporarily. if i was playing against bots in Q3, i would occasionally see "x joined game" from the console, and then i would get the crazy mouse effects, as if i was fighting for control. keep in mind that any time you play Q3 multiplayer, you are running a listen server, and if someone sees that on the internet, they can try to join. since you are the only human player, they will be conflicting with you.

anyway, when i set it so that i was a "private" server, it stopped. also, are you playing vanilla q3? or a mod? i had this problem in a mod that was for multiplayer only which by default was an open server, i believe it was OSP.

or maybe i forgot to take my meds that day.


I kind of thought it was the Vid drivers so I installed the 28.32 and still had the same problems.

This problem happens with all the games not just one game. Quake 3 I play a mod called Urban Terror. And I also have Max Payne installed. Both give the same result, so I know that it's XP. Maybe DLL that is not getting overwritten? Just don't know!

I don't think its anyone connecting to my machine as I run a Hardware firewall and a sofware firewall. In order for someone to gain access to my machine I would have to give them permission.

Like I said I am going to install another version of XP on an alternate partition and install the game on there and see what happens.

The only reason I even posted in this post is because I have noticed that a lot of peeps are having similar problems!

Thanks for all the replies though!!!


I've found out why it does what it did.
When I reinstalled the computer and put Windows 2000 on, I used Norton Personal Firewall 2002 as the chosen firewall. I was using Zonealarm (free version) on Windows XP. Since then, I have reinstalled the computer - putting Windows 2000 back on the system, but installed Zonealarm Pro on as the firewall (My gf found it easier to use than NPF). The wacky mouse came back. I turned off Zonealarm Pro and problem solved. I reinstalled Norton Personal Firewall 2002 and still the problem didnt return.

I'm gonna reinstall Windows XP this weekend with NPF2002 to see if that fixes the problem - but I have to admit, it looks promising :D

Perhaps thats the same problem that everyone else is experiencing?

because afterall, everyone seems to be only getting the problem if they play the games online or if someone connects to their game. So its possibly something in the Quake III Arena netcode that Zonealarm fecks up??


Win9X, W2K and now WinXP and Never had a problem. Never used a wireless mouse. I've used MS Opticals and now a Logitech Dual Optical.
I am getting DSL next week (YEA!) so I'll post back if I see anything as a result of a firewall.

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
What a long strange trip it's been. =)

Forum statistics

Latest member