Q3A Help

Anakist

Way too much time here...
#1
When I try to play Q3A I get this.

Q3 1.11 win-x86 Nov 24 1999
----- FS_Startup -----
Current search path:
C:\James\Quake III Arena/baseq3
F:\Quake3\\baseq3\pak1.pk3 (7 files)
F:\Quake3\\baseq3\pak0.pk3 (3539 files)
F:\Quake3\/baseq3

----------------------
execing default.cfg
execing q3config.cfg
couldn't exec autoexec.cfg
...detecting CPU, found x86 (P5/Pentium2, MMX)

------- Input Initialization -------
Initializing DirectInput...
Couldn't set DI coop level
Falling back to Win32 mouse support...
Joystick is not active.
------------------------------------
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
--- Common Initialization Complete ---
Winsock Initialized
Opening IP socket: localhost:27960
Hostname: antheacurtis
IP: 127.0.0.1
Working directory: C:\James\Quake III Arena
fs_cdpath is write protected.
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\SYSTEM\opengl32.dll' ): succeeded
...setting mode 3: 640 480 FS
...using desktop display depth of 16
...calling CDS: ok
...registered window class
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...23 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...23 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...setting mode 3: 640 480 FS
...using colorsbits of 16
...calling CDS: ok
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...23 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...23 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...shutting down QGL
...unloading OpenGL DLL
...assuming '3dfxvgl' is a standalone driver
...initializing QGL
...WARNING: missing Glide installation, assuming no 3Dfx available
...shutting down QGL
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
GLW_StartOpenGL() - could not load OpenGL subsystem
How do I fix this??

James
 

Octopus

OSNN Veteran Addict
#2
C:\James\Quake III Arena/baseq3
F:\Quake3\\baseq3\pak1.pk3 (7 files)
F:\Quake3\\baseq3\pak0.pk3 (3539 files)
F:\Quake3\/baseq3

did you install Q3 in a diffrent drive and Q3A in the 2nd one?you should install both in the same folder(I think)
 

Kr0m

OSNN Veteran Addict
#3
I think "GLW_StartOpenGL() - could not load OpenGL subsystem" is the culprit.

Just a short while ago I decided to upgrade my video drivers and Direct X. I installed my vid drivers first then DX9 which I guess was a mistake. I think I had a similiar error with Q3. All I did to fix it was reinstall my vid drivers and Q3 started right up. Hopefully this will fix it.
 

Anakist

Way too much time here...
#4
yeah dx9 was the culprit. I went to openglsetup.com or something like that and downloaded the opengl drivers for the vid card and it all works good now.

Thanks.

James
 
#5
I wouldnt've installed the drivers from GL Setup myself... I would've downloaded the latest detonators from nvidia.com and installed them (that would've installed openGL correctly)
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,971
Messages
673,299
Members
89,016
Latest member
Poseeut