• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Problem Networking XP 'n 98SE

khotwadi

OSNN One Post Wonder
#1
Im trying to network 2 computers at home using crossover cables.
One is running XP Professional 'n the other 98SE.

I wont be able to share the internet coz theres just 1 NIC on this machine so it can be either used for internet or networking the 2 pcs.

I followed this link to network the 2 of them.
http://www.homenethelp.com/web/howto/net.asp
Since Im not going to use the net I'll have to put in static IP in both of them which I put as 192.168.10.100 on this machine and 192.168.10.101 on the other one and subnet mask as 255.255.255.0 in both the machines.

I also put them in the same workgroup and i also enabled NetBios over TCP/IP in Xp.Now the problem is that in 98SE in the Network Neighborhood I can see that machine itself but not XP and in My Network Places in XP there r no machines in the workgroup computers.

Also when I ping from 98SE to XP I get proper response but its not the same case vice versa.In 98SE when I type the command "net view" it only shows that computer in the workgroup.

I face the same problem when I use the Network Setup Wizard in XP to set it up for networking.

Plz help.

Also I would appreciate if you can insert some links
to other Windows networking forums which u know.

Khotwadi.
 
#2
i glanced over your note and it looks correct so far. i had this same problem myself a while back. i solved it by installing the netbeui protocol on the xp pro machine. just pop in the xp cd and look for the valueadd folder.

in win98se, netbeui is installed by default. after a quick reboot, both machines should be able to see the other.
 
#3
it's funny the network setupwizard didn't work.

i tried networking these two before and all i did was to start XP before the 98 machine and XP did all the work.
 

Tweakfiend

OSNN Senior Addict
#5
koko said:
i glanced over your note and it looks correct so far. i had this same problem myself a while back. i solved it by installing the netbeui protocol on the xp pro machine. just pop in the xp cd and look for the valueadd folder.

in win98se, netbeui is installed by default. after a quick reboot, both machines should be able to see the other.
The 2 files required are 1) nbf.sys 2) netnbf.inf.......quickest way by "Start" ,"search" , cd drive.
Save in System 32 , Windows/Inf , respectively.
 

j79zlr

Glaanies script monkey
Political User
#6
You have to add the File and Printer sharing Network Service on 98, it isn't there by default. You also have to add a account with a username and password on the 98 machine identical to one on the XP machine.

Don't run the networking wizard, it screws stuff up.
 

toretto

Mentally Absent
#7
you also have to make sure that the firewall isnt set to high in xp. or that an add on firewall that you may have downloadeded isnt screwing it up. in sp2, it might ask to unblock them.

one thing you might try in xp and 98, is to go up the chain of the network, aka, view the "entire microsoft network" and go from there, sometimes in 98 you have to go the long route sometimes, and then log into the xp machine manually my right clicking the computer and then telling it to log in the machine with a user and password.
 
#8
not sure if this helps, but my wife brought home an older laptop with win98 (not se) and asked me to connect it to the network.

i plugged in the gateway, 2 dns servers and an ip and it connected without a hitch.
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,014
Latest member
sanoravies