ping across network

I have mandrake 10.1 installed with all updates along with samba server and SMB4K. I am trying to share files with a windows XP box. (note: no firewalls on either machine and the firewall on router is disabled). I can see winXP from my Linux machine fine using SMB4K. I have played with the smb.conf file and changed my workgroup to the same workgroup as my winXP box. From my winXP box, I can ping the linux box with good replys. However, when I ping winXP from linux, I get no replys. The command I am using in the console is: ping -c 5

Also, on the winXP i can goto network places and see the workgroup. When I open the workgroup I can see the samba server, but I cant access it. I think thats a permissions issue, that I will work out later. I can ping the router fine.

But I was curious why I have a pinging issue?



Political User
1. Seems like you have something on XP that is blocking pings. The built in firewall perhaps? The samba server should have nothing to do with this.
2. If you have it set up as a workgroup, I would make sure that your XP login name actually has an account in the samba server.


Political User
Is your Windows XP firewall on? (SP2 this is standard i believe), also check that if it is on, that you are not discarding ICMP packets.

But more than that i don't know, i have no clue why it would not work.
yep all firewalls are off. I guess it is no big deal though because I can see my windows machine from linux and thats the way it won't ping. the pinging issue just seems wierd. :rolleyes:

I am still trying to get my samba setup so windows can see linux. i can get it to work mometarily but then it dies. But not asking for help on that yet. I am determined to look most of this stuff up myself. There is alot of help out there if ya look. I have SWAT installed now.. it seems abit easier, but still playing.

Thanks fellas!
getting closer. I got my mappings to work. In XP, using my network would see the workgroup but couldnt connect to the share. I was able to however, bypass the netbios name in thr un box by: \\\Sharename and it worked. So I opened windows explore and mapped it via : \\netbios name\sharename and all works well, except for one little bitty factor. I seem to only have read only.

Using SWAT, i have NO for read only. SO I am not for sure what is causing this. Im sure I will finger it out sooner or later. Still baffled about the ping thing though.


Political User
When you standard connect to a remote samba server, it will use your current logged on credentials.

Create a new home account, use SWAT to set a password, then when you map the drive, select "use other username or password to connect" fill in the details, and you are set.
vern said:
What was wrong with your setup?
sorry bout that. I ended up in the smb.conf file... changing the "security=user" to "security=share". also the wierdest thing to was on my laptop (windows) I ended up with an aftermarket firewall on. wierd because I always disable them. that was my ping issue. Duh me...


Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
What a long strange trip it's been. =)

Forum statistics

Latest member