NTFS file permissions problem



I have one heck of a problem. I locked my Documents and Settings file from any user using WinXP Corp. After a while my .dmp packets (or something) became corrupt and i am no longer able to access my copy of windows and my pc. Do you know of a way (bein the NTFS guru's that you guys are) of accessing my folders and retrieving my files? It says i do not have the required permissions to access the folder. Your help would be greatly appreciated. (BTW it gives me the error message i guess because my hd is in someone else's pc) :eek:


Thats the whole point of NTFS... If you dont have the permissions you dont get access. You need to be Administrator or someone has to have administrator access.
The hd being in someone elses pc could be the problem if the drive is a slave and you dont have admin accessible account. The files are owned by the creator. The creator also has a SID ( Security IDentifier ) attached to his/her account. Even though you create an account with the same username ( aka owner ) It wont work. Someone who has admin access can save the files and do what is needed to make them accessible to you.


Beware the G-Man
Political User
Tiny little voices are telling me that I can not tell you anything. :cool:


Maybe if you call MicroSquish, they might be able to help, since it IS a "Corporate Version" of their XP Operating System.

If I find their number i will post it for you. :cool:

You might want to put the HDD back in the machine it came from... then maybe you can get the Admin to open the files for you.

Just a thought. :happy:



I am having a similar problem. I am using XP home and due to a virus my installation of XP got corrupted and various system files were deleted.

I have installed a fresh version of xp on a separate hdd so that i can try and retrieve my old documents, but i am locked out of them. Any ideas of how to regain access to them?

This is the error i am getting:

Paras Haria
E:\Documents and Settings\Paras Haria\My Documents is not accessible.

Access is denied.


ok... I think I should clarify some things.

1 you cant delete critical system files. if you reboot they come back. thats part of the design of XP

2 if you do not have admin rights on a machine you can not access other peoples profiles or folders.

3 Access Denied is NOT an NTFS problem or corruption. It means you do not have admin access and/or the folder or file in question is only accessable by the owner of that folder.

I might be wrong but I doubt it, I just think are trying to access something not belonging to you.


I basically have the same problem with WinXP. On bootup the error message, corupt or missing windows\system32\drivers\ntfs.sys file. I installed XP over the top but on reboot, the same message appears. How before I installed a fresh install, I want to save the files of the three people who log into this computer.

One has a password and the other two don't at logon time. By taking the hard drive into another machine, I can copy over the two that don't require a password to logon, but the other one is not accessible. This users files are very important so I have tried several things to get access without any luck. I can access the folders if I bootup with knoppix (Linux) and open some of the doc. files but can not copy the files on the NTFS hard drive or another fat32 drive.

I also have administrator rights, but this still doesn't give me access. If someone can help, it would be greatly appreciated.


Found part of the answer to our problem by reading whatfarseeker had previously said in a posting, and figured out the rest by myself. His advise got me into the persons folder but I still couldn't access his "My Documents" folder, where all the data was that we needed to save. After some mucking around I found the answer. Here are the full instructions, in three steps:

1. Log on as an administrator and go to control panel, Folder Options. In the View tab, untick "Use Simple File Sharing"

2. Now go to the folder of the person you can not access in Documents and Settings, right click on that folder, properties, security. Click on the add button and type in your login name and click Ok. Then give yourself full control, click OK.

This will now allow you access to the persons folder, however you can still not access "My Document" folder until you take ownership. So follow the next step.

3. Right click on "My Documents" the folder you can not access and click on Properties, Security. You will receive a message saying (you can not set permissions but you can take ownership) or something to this effect. When you click OK, you're find out the you can not add or set permissions as they are greyed out, however you now click on advance button. In the next dialog box, click on the Owner tab, and highlight your account name and tick the box "Replace owner on subcontainers and objects" Now click OK, OK and you will be able to access all the folders in "My Documents"

Now I can go to bed, cheers everyone from New Zealand

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
What a long strange trip it's been. =)

Forum statistics

Latest member