• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Need For Speed: Underground 2 Problems

indyjones

OSNN.net Adventurer
#1
Hey All
On Friday I went out and got Half-life2 and NFS:U2.
Ever since installing underground 2 I have had nothing but problems.
Firstly the game will not start at all (error in Speed2.exe) error message comes up.
So to try and fix that, I used a nocd patch. This allowed the game to run at least.
The problem now is that it hangs on loading screens. A little progress bar goes along but nothing happens :(
I have got into the game a couple of times and once I was in it was all peachy but this is just annoying!
I have installed the 1.1 patch for it which in itself was worrying as it came out before the uk version was released!
Any help would be very much appreciated
 

indyjones

OSNN.net Adventurer
#3
*BUMP* Does nobody know? :( I have does some web searching and it seems to be a fairly common problem, and frekin EA Support have not bother replying yet :(
I can get the game to run using a nocd patch but as its for the US version rather than the UK it does cause the game to hang at loading screen so is not a solution
 

indyjones

OSNN.net Adventurer
#7
I have got it, fat load of good that it is *grumble grumble moan* at least I got half-life 2 at the same time to keep me occupied, mind you I am a little FPS'ed out as my last games were starwars battlefront, and doom3 before that....


Oh! Thanks anyway, :)
 

mbx

Marathon Project
#8
OMG, you're my gaming twin :eek:
I've just installed HL2 (and am about to get NFS:U2) after having played Battlefront and Doom3 to death.
 

indyjones

OSNN.net Adventurer
#9
heheh, I finished just about everything in battlefront though got bored with doom3 as it felt sooo samey, to date my fav FPS is farcry, though by the looks of it (too early to tell) half-life 2 could trash that :)
 

indyjones

OSNN.net Adventurer
#10
Here is my response :mad:
Subject
speed2.exe has encountered a problem and needs to close. - Start Up Problem

Q&A History
EA Response (Jody) 23/11/2004 10:15 AM
Hi

Thank you for contacting Electronic Arts UK Technical Support

With regards to your problem, you will need to uninstall and then reinstall the game.

After you have uninstalled, but before you reinstall, you will need to clean your system out. To do this, please follow these instructions:

Firstly:
Right-click on My Computer and choose Properties. Click on the Hardware tab and then click on the Device Manager button.

Double-click on IDE ATA / ATAPI Controllers, double click on Primary and then click on the Settings tab (menu title) up the top. Next to "Transfer Mode" select 'PIO Only' for Device 1. Leave Device 0 (Zero) as 'DMA if Available'. Click OK and then double click on the Secondary Channel and then click on the Settings tab (menu title) up the top. Next to "Transfer Mode" select 'PIO Only' for both Device 0 and Device 1.

You'll need to reboot before it takes effect. You can check it has worked by going back into the same screen, and adjacent to "Current Transfer Mode" it should read "PIO Mode".

Just so you know, DMA (Direct Memory Access) is a faster way of getting data from CD-ROMs or Hard drives than PIO (Programmable Input / Output). It is also less stable, and can cause problems with installing or running games.

Secondly:

Double Click on My Computer

Now open the drive that your Windows folder is located in, default is C:

Now locate your TEMP directory and delete the contents. BE SURE TO NOT DELETE ANYTHING ELSE


Thirdly:

Left Click on Start and go to Run

Type in MSCONFIG and then hit the return button

When the utility loads up, place a dot in SELECTIVE start up

Now click the tab at the top titled START UP

Running down the left hand side, you will see white boxes with black ticks, untick every box apart from the one marked SYSTRAY (if listed). Don't forget to use your scroll bar on the right hand side and go down further. Once completed, click APPLY in the bottom right hand corner and then click on CLOSE

Restart the PC when prompted and then start the game


You should now be able to reinstall.

If you experience anymore problems do not hesitate to contact us.

I hope this helps.

Best Regards,

Jody
EA Support Centre, UK and Ireland
It looks far too generic and does not seem at all constructive to me
 

indyjones

OSNN.net Adventurer
#11
Right I am nt fiddling with PIO Only modes everything else works as it should and I dont want to lose the full ability of one of my drives.
I have however had an idea this is to remove the Nforce drivers for my IDE chipset as these have proven to be problomatic in the the past.
It now starts loading up and the screen goes black the res changes then..........it drops out :( still it no longer comes up with the error message so I guess that I have made progress??
 

indyjones

OSNN.net Adventurer
#12
YAY I have fixed it, the culprit was my Nforce drivers (was using the beta ones from this site) went allllllll the way back to my 4.27 drivers (just to be sure) (anyway its nforce 2 so the drivers should be fine back then) and walla it plays perfect :D
 

indyjones

OSNN.net Adventurer
#13
Please Read The Thread Before Emailing People

Ok clearly this has now become slightly annoying. I have recently received two emails regarding this post. This is all well and good except that 1) it does not appear to be members from this site and 2) they are not bothering to read what I said before.

So once again here is my PERSONAL solution (it might not help everybody).

Upon buying the game when I tried to start it I was just met with “error in Speed2.exe” and despite contact EAGAMES their help was near useless, it did however give me an idea. I always used to get issues when using the IDE drivers supplied with my Nvidia Nforce2 mainboard drivers. So I uninstalled the drivers and went back to an old version (where my chipset is fairly old, I don’t need the very latest drivers) and did a custom install of the drivers, making sure the IDE SW drivers are NOT installed. Since then all is peachy.

There is another factor which can cause this error and that is if you are using a dodgy copy with a dodgy nocd patch (although a lot of us use them with retail games) simply download another nocd patch and it might fix this problem.
 

pendyal

OSNN One Post Wonder
#14
nfs underground1

hi every1,
i am not sure if this is the right place but i have trouble with nfs underground1.in the underground mode as soon as i am proceed to race 25,the game is exiting.everything is fine with the quick race mode.cud some1 please help me..

thanks..

bye..
 

megamanchris

OSNN One Post Wonder
#15
I’m in a bit of a sticky spot of trouble myself only mine is much worse. I am not even on the map, in fact I think I’m past the airport in the air because plains are flying around me but the worst bit is I can't move please help me. I’m begging you!!!:cry:
 

stlee

OSNN One Post Wonder
#16
NOT JUZ U GOT THE PROBLEM , ME 2, GOT PROBLEM IN speed2.exe AND MY NFSU2 IS V1.2 . I USE WINDOW XP PROFFESIONAL SP2,DOES IT EFFECT OR NOT???ANYONE CAN HELP ME
 

Nick

OSNN Lurker
#17
Who'd've thought this post would've attracted so many new members? :)

Although I can't offer any help, you'll get a much better reponse from people if you explain clearly what problems your having and give as much relevant detail as you can, as the previous couple of posts are a bit sparse on facts.

@Pendyal: I'd look for a thread relating to NFS:U1, as this thread is related to NFS:U2. If there isn't one about, I'd start your own, and give as much detail as possible.
 
#18
New members are great but there's plenty of space to type whole words out...... and someone needs to unstick their capslock....

Sp2 incidentally causes no problems to any game what so ever. Without further complete detail I cannot assist further
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,014
Latest member
sanoravies